InverseMatrixState Enumeration

A Matrix3d is tagged indicating one of the following states:

  • unknown: it is not know if the matrix is invertible.
  • inverseStored: the matrix has its inverse stored.
  • singular: the matrix is known to be singular.

Members

Name Value Description
unknown 0 The invertibility of the coffs array has not been determined.
Any inverseCoffs contents are random.
inverseStored 1 An inverse was computed and stored as the inverseCoffs
singular 2 The coffs array is known to be singular.
Any inverseCoffs contents are random.

Defined in

Last Updated: 20 June, 2023