intersectSegment MethodStatic

Compute the intersection of a line (parameterized as a line segment) with the plane of this polygon.

intersectSegment(polygon: Point3d[] | IndexedXYZCollection, point0: Point3d, point1: Point3d, tolerance: number = Geometry.smallMetricDistance, result?: PolygonLocationDetail): PolygonLocationDetail

see PolygonOps.intersectRay3d

Parameter Type Description
polygon Point3d[] | IndexedXYZCollection points of the polygon, closure point optional
point0 Point3d start point of segment on line to intersect
point1 Point3d end point of segment on line to intersect
tolerance number optional distance tolerance to determine point-vertex and point-edge coincidence.
result PolygonLocationDetail optional pre-allocated object to fill and return

Returns - PolygonLocationDetail

details d of the line-plane intersection d.point:

  • d.isValid() returns true if and only if the line intersects the plane.
  • d.code indicates where the intersection lies with respect to the polygon.
  • d.a is the segment intersection parameter. If d.a is in [0,1], the segment intersects the plane of the polygon.
  • d.edgeIndex and d.edgeParam specify the location of the closest point on the polygon to the intersection, within distTol.

Defined in

Last Updated: 20 June, 2023