sumTriangleAreasPerpendicularToUpVector MethodStatic

Sum areas of triangles from points[0] to each far edge, as viewed with upVector pointing up.

  • Consider triangles from points[0] to each edge.
  • Sum the areas perpendicular to the upVector.
  • If the upVector is near-zero length, a simple z vector is used.

sumTriangleAreasPerpendicularToUpVector(points: Point3d[] | GrowableXYZArray, upVector: Vector3d): number

Parameter Type Description
points Point3d[] | GrowableXYZArray  
upVector Vector3d  

Returns - number

sum of triangle areas.

Defined in

Last Updated: 20 June, 2023