StandardViewIndex Enumeration

Standard views. Used in Matrix3d.createStandardViewAxes(index: StandardViewIndex, invert: boolean)

Members

Name Value Description
Top 1 X to right, Y up
Bottom 2 X to right, negative Y up
Left 3 negative Y to right, Z up
Right 4 Y to right, Z up
Front 5 X to right, Z up
Back 6 negative X to right, Z up
Iso 7 isometric: view towards origin from (-1,-1,1)
RightIso 8 right isometric: view towards origin from (1,-1,1)

Defined in

Last Updated: 20 June, 2023