IModelJson Namespace
ImodelJson
namespace has classes for serializing and deserialization json objects
Class
Name | Description |
---|---|
IModelJson.Reader | parser services for "iModelJson" schema |
IModelJson.Writer | Class to deserialize json objects into GeometryQuery objects |
Interface
Name | Description |
---|---|
IModelJson.ArcByVectorProps | Interface for Arc3d value defined by center, vectorX, vectorY and sweepStartEnd. |
IModelJson.AxesProps | * There are multiple ways to specify an orientation |
IModelJson.BSplineSurfaceProps | Property rules for json objects that can be deserialized to a BsplineSurface |
IModelJson.BcurveProps | Interface for bspline curve (aka bcurve) |
IModelJson.BoxProps | Interface for Box (or frustum with all rectangular sections parallel to primary xy section). |
IModelJson.ConeProps | Interface for Cone value defined by centers, radii, and (optional) vectors for circular section planes. |
IModelJson.CurveCollectionProps | Interface for a collection of curves, eg. |
IModelJson.CurvePrimitiveProps | Property rules for json objects that can be deserialized to various CurvePrimitives |
IModelJson.CylinderProps | Interface for cylinder defined by a radius and axis start and end centers. |
IModelJson.GeometryProps | Property rules for json objects that can be deserialized to various Curve and Solid objects |
IModelJson.IndexedMeshProps | Interface for an indexed mesh. |
IModelJson.LinearSweepProps | Interface for a linear sweep of a base curve or region. |
IModelJson.PlanarRegionProps | Interface for a collection of curves that bound a planar region |
IModelJson.PointProps | Property rules for json objects that can be deserialized to single point |
IModelJson.RotationalSweepProps | Interface for a rotational sweep of a base curve or region around an axis. |
IModelJson.RuledSweepProps | Interface for a surface with ruled sweeps between corresponding curves on successive contours |
IModelJson.SolidPrimitiveProps | Interface for solid primitives: box, sphere, cylinder, cone, torusPipe, linear sweep, rotational sweep, ruled sweep. |
IModelJson.SphereProps | Interface for Sphere (with optionally different radius to pole versus equator) |
IModelJson.TaggedNumericDataProps | Interface for extra data attached to an indexed mesh. |
IModelJson.TorusPipeProps | Interface for TorusPipe data |
IModelJson.TransitionSpiralProps | Interface for spiral |
Defined in
Last Updated: 20 June, 2023