DistanceTool Class
Tool for measuring distances and placing Markups of them
Extends
Methods
Name | Description | |
---|---|---|
constructor(_arrowPos?: string): DistanceTool | ctor for ArrowTool | |
createMarkup(svgMarkup: G, ev: BeButtonEvent, isDynamics: boolean): void Protected | ||
getFormattedDistance(distance: number): undefined | string Protected | ||
onDataButtonDown(ev: BeButtonEvent): Promise<EventHandled> | Invoked when the data button is pressed. | |
setupAndPromptForNextAction(): void Protected | ||
showPrompt(): void Protected |
Inherited methods
Name | Inherited from | Description |
---|---|---|
applyToolSettingPropertyChange(_updatedValue: DialogPropertySyncItem): Promise<boolean> | ArrowTool | Used to receive property changes from UI. |
autoLockTarget(): void | ArrowTool | Called on data button down event to lock the tool to its current target model. |
beginDynamics(): void | ArrowTool | Call to initialize dynamics mode. |
bumpToolSetting(_settingIndex?: number): Promise<boolean> | ArrowTool | Used to "bump" the value of a tool setting. |
changeLocateState(enableLocate: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void | ArrowTool | Helper method to keep the view cursor, display of locate circle, and coordinate lock overrides consistent with isLocateEnabled and isSnapEnabled. |
changeToolSettingPropertyValue(syncItem: DialogPropertySyncItem): boolean | ArrowTool | Helper method for responding to a tool setting property value change by updating saved settings. |
clearDynamicsMarkup(_isDynamics: boolean): void Protected | ArrowTool | |
decorate(_context: DecorateContext): void | ArrowTool | Called to allow an active tool to display non-element decorations in overlay mode. |
decorateSuspended(_context: DecorateContext): void | ArrowTool | Called to allow a suspended tool to display non-element decorations in overlay mode. |
endDynamics(): void | ArrowTool | Call to terminate dynamics mode. |
exitTool(): Promise<void> | ArrowTool | |
filterHit(_hit: HitDetail, _out?: LocateResponse): Promise<LocateFilterStatus> | ArrowTool | Invoked to allow tools to filter which elements can be located. |
getCurrentButtonEvent(ev: BeButtonEvent): void | ArrowTool | Fill the supplied button event from the current cursor location. |
getDecorationGeometry(_hit: HitDetail): undefined | GeometryStreamProps | ArrowTool | Called to allow snapping to pickable decoration geometry. |
getOrCreateArrowMarker(color: string): Marker Protected | ArrowTool | |
getPrompt(): string | ArrowTool | Returns the prompt based on the tool's current state. |
getToolSettingPropertyLocked(_property: DialogProperty<any>): undefined | DialogProperty<any> | ArrowTool | Override to return the property that is disabled/enabled if the supplied property is a lock property. |
getToolTip(_hit: HitDetail): Promise<string | HTMLElement> | ArrowTool | Invoked before the locate tooltip is displayed to retrieve the information about the located element. |
initLocateElements(enableLocate?: boolean, enableSnap?: boolean, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void | ArrowTool | Helper method for tools that need to locate existing elements. |
initializeToolSettingPropertyValues(properties: DialogProperty<any>[]): void | ArrowTool | Helper method to establish initial values for tool setting properties from saved settings. |
isCompatibleViewport(vp: undefined | Viewport, isSelectedViewChange: boolean): boolean | ArrowTool | |
isComplete(_ev: BeButtonEvent): boolean Protected | ArrowTool | |
isValidLocation(ev: BeButtonEvent, isButtonEvent: boolean): boolean | ArrowTool | Checks that the adjusted point from the supplied button event is within the project extents for spatial views. |
onAdded(el: Element): void Protected | ArrowTool | |
onCleanup(): Promise<void> | ArrowTool | Invoked when the tool becomes no longer active, to perform additional cleanup logic |
onDataButtonUp(_ev: BeButtonEvent): Promise<EventHandled> | ArrowTool | Invoked when the data button is released. |
onDynamicFrame(_ev: BeButtonEvent, _context: DynamicsContext): void | ArrowTool | Called to allow Tool to display dynamic elements. |
onInstall(): Promise<boolean> | ArrowTool | |
onKeyTransition(_wentDown: boolean, _keyEvent: KeyboardEvent): Promise<EventHandled> | ArrowTool | Called when any key is pressed or released. |
onMiddleButtonDown(_ev: BeButtonEvent): Promise<EventHandled> | ArrowTool | Invoked when the middle mouse button is pressed. |
onMiddleButtonUp(_ev: BeButtonEvent): Promise<EventHandled> | ArrowTool | Invoked when the middle mouse button is released. |
onModifierKeyTransition(_wentDown: boolean, _modifier: BeModifierKeys, _event: KeyboardEvent): Promise<EventHandled> | ArrowTool | Called when Control, Shift, or Alt modifier keys are pressed or released. |
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled> | ArrowTool | Invoked when the button is released after onMouseStartDrag. |
onMouseMotion(ev: BeButtonEvent): Promise<void> | ArrowTool | Invoked when the cursor is moving |
onMouseStartDrag(_ev: BeButtonEvent): Promise<EventHandled> | ArrowTool | Invoked when the cursor begins moving while a button is depressed. |
onMouseWheel(_ev: BeWheelEvent): Promise<EventHandled> | ArrowTool | Invoked when the mouse wheel moves. |
onPostInstall(): Promise<void> | ArrowTool | |
onRedoPreviousStep(): Promise<boolean> | ArrowTool | Called to reinstate to a previous tool state (ex. |
onReinitialize(): Promise<void> | ArrowTool | Called to reset tool to initial state. |
onResetButtonDown(_ev: BeButtonEvent): Promise<EventHandled> | ArrowTool | Invoked when the reset button is pressed. |
onResetButtonUp(_ev: BeButtonEvent): Promise<EventHandled> | ArrowTool | Invoked when the reset button is released. |
onRestartTool(): Promise<void> | ArrowTool | |
onSelectedViewportChanged(_previous: undefined | Viewport, current: undefined | Viewport): Promise<void> | ArrowTool | Called when active view changes. |
onSuspend(): Promise<void> | ArrowTool | Notification of a ViewTool or InputCollector starting and this tool is being suspended. |
onTouchCancel(ev: BeTouchEvent): Promise<void> | ArrowTool | |
onTouchComplete(ev: BeTouchEvent): Promise<void> | ArrowTool | |
onTouchEnd(_ev: BeTouchEvent): Promise<void> | ArrowTool | Called when user removes a touch point by lifting a finger or stylus from the surface. |
onTouchMove(ev: BeTouchEvent): Promise<void> | ArrowTool | |
onTouchMoveStart(ev: BeTouchEvent, startEv: BeTouchEvent): Promise<EventHandled> | ArrowTool | |
onTouchStart(_ev: BeTouchEvent): Promise<void> | ArrowTool | Called when user adds a touch point by placing a finger or stylus on the surface. |
onTouchTap(_ev: BeTouchEvent): Promise<EventHandled> | ArrowTool | Called when touch point(s) are added and removed from a surface within a small time window without any touch point moving. |
onUndoPreviousStep(): Promise<boolean> | ArrowTool | Called to reverse to a previous tool state (ex. |
onUnsuspend(): Promise<void> | ArrowTool | |
outputMarkupPrompt(msg: string): void Protected | ArrowTool | |
parseAndRun(..._args: string[]): Promise<boolean> | ArrowTool | Run this instance of a tool using a series of string arguments. |
pickElement(pt: Readonly<WritableXAndY>): undefined | Element | ArrowTool | Find the topmost MarkupElement at the specified point in the markup view. |
provideToolAssistance(mainInstrKey: string, singlePoint: boolean = false): void Protected | ArrowTool | |
redoPreviousStep(): Promise<boolean> | ArrowTool | |
reloadToolSettingsProperties(): void | ArrowTool | Called by tool to inform UI to reload ToolSettings with new set of properties. |
requireWriteableTarget(): boolean | ArrowTool | |
run(..._args: any[]): Promise<boolean> | ArrowTool | Establish this tool as the active PrimitiveTool. |
saveChanges(): Promise<void> | ArrowTool | If this tool is editing a briefcase, commits any elements that the tool has changed, supplying the tool name as the undo string. |
setCurrentStyle(element: Element, canBeFilled: boolean): void Protected | ArrowTool | |
setCurrentTextStyle(element: Element): void Protected | ArrowTool | |
supplyToolSettingsProperties(): undefined | DialogItem[] | ArrowTool | Used to supply list of properties that can be used to generate ToolSettings. |
syncToolSettingsProperties(syncData: DialogPropertySyncItem[]): void | ArrowTool | Called by tool to synchronize the UI with property changes made by tool. |
testDecorationHit(_id: string): boolean | ArrowTool | Called to support operations on pickable decorations, like snapping. |
undoPreviousStep(): Promise<boolean> | ArrowTool | |
register(namespace?: string): void Static | ArrowTool | Register this Tool class with the ToolRegistry. |
Properties
Name | Type | Description | |
---|---|---|---|
_startPointWorld ProtectedReadonly | Point3d | ||
iconSpec Static | string | The icon for this Tool. | |
toolId Static | string | The unique string that identifies this tool. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_arrowPos Protected | undefined | string | ArrowTool | |
_minPoints Protected | number | ArrowTool | |
_nRequiredPoints Protected | number | ArrowTool | |
_points ProtectedReadonly | Point3d[] | ArrowTool | |
briefcase Accessor ReadOnly | undefined | BriefcaseConnection | ArrowTool | Get the briefcase on which this tool operates, if the tool has successfully installed and the target ArrowTool.iModel is a briefcase. |
description Accessor ReadOnly | string | ArrowTool | Get the localized description string from this Tool's class |
description Accessor StaticReadOnly | string | ArrowTool | Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, ArrowTool.flyover is returned. |
englishKeyin Accessor StaticReadOnly | string | ArrowTool | Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
flyover Accessor ReadOnly | string | ArrowTool | Get the localized flyover string from this Tool's class |
flyover Accessor StaticReadOnly | string | ArrowTool | Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, ArrowTool.keyin is returned. |
hidden Static | boolean | ArrowTool | If true, this Tool will not appear in the list from getToolList. |
iconSpec Accessor ReadOnly | string | ArrowTool | Get the iconSpec from this Tool's class. |
iModel Accessor ReadOnly | IModelConnection | ArrowTool | Get the iModel on which this tool operates. |
isControlDown Accessor ReadOnly | boolean | ArrowTool | Convenience method to check whether control key is currently down without needing a button event. |
isDynamicsStarted Accessor ReadOnly | boolean | ArrowTool | Call to find out if dynamics are currently active. |
keyin Accessor ReadOnly | string | ArrowTool | Get the localized keyin string from this Tool's class |
keyin Accessor StaticReadOnly | string | ArrowTool | Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
markup | Markup | ArrowTool | |
maxArgs Accessor StaticReadOnly | undefined | number | ArrowTool | The maximum number of arguments allowed by ArrowTool.parseAndRun, or undefined if there is no maximum. If subclasses override ArrowTool.parseAndRun, they should also override this method to indicate the maximum number of arguments their implementation expects. |
minArgs Accessor StaticReadOnly | number | ArrowTool | The minimum number of arguments allowed by ArrowTool.parseAndRun. If subclasses override ArrowTool.parseAndRun, they should also override this method to indicate the minimum number of arguments their implementation expects. UI controls can use this information to ensure the tool has enough information to execute. |
namespace Static | string | ArrowTool | The namespace that provides localized strings for this Tool. |
receivedDownEvent | boolean | ArrowTool | Used to avoid sending tools up events for which they did not receive the down event. |
targetIsLocked | boolean | ArrowTool | |
targetModelId Accessor | undefined | string | ArrowTool | |
targetView | undefined | Viewport | ArrowTool | The viewport within which the tool operates. |
toolId Accessor ReadOnly | string | ArrowTool | Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize the keyin, description, etc. from the current locale. |
toolKey Static | string | ArrowTool |
Defined in
- markup/src/RedlineTool.ts Line 359
Last Updated: 20 June, 2023