PopupProps Interface

Properties for the Popup component

Extends

Methods

Name Description
onClose(): void Optional Function called when the popup is closed  
onContextMenu(e: MouseEvent): void Optional Function called when the right mouse button is pressed  
onEnter(): void Optional Function called when the popup is closed on Enter  
onOpen(): void Optional Function called when the popup is opened  
onOutsideClick(e: MouseEvent): void Optional Function called when user clicks outside the popup  
onWheel(e: WheelEvent): void Optional Function called when the wheel is used  

Properties

Name Type Description
animate undefined | boolean Indicates whether to use animation for open/close (defaults to true)  
ariaLabel undefined | string accessibility label  
closeOnContextMenu undefined | boolean Indicates whether to close the popup when the right mouse button is pressed (defaults to true)  
closeOnEnter undefined | boolean Indicates whether to close the popup when Enter is pressed (defaults to true)  
closeOnNestedPopupOutsideClick undefined | boolean If false outside click processing and closing are skipped if click occurs in another Popup component, default to false.  
closeOnWheel undefined | boolean Indicates whether to close the popup when the wheel is used (defaults to true)  
focusTarget string | RefObject<HTMLElement> Element to receive focus, specified by React.RefObject or CSS selector string.  
isOpen boolean Indicates whether the popup is shown or not (defaults to false)  
isPinned undefined | boolean Indicates whether the popup is pinned.  
keepContentsMounted undefined | boolean If true the children are mounted once and unmounted when this component is unmounted.  
left number Left position (absolute positioning - defaults to 0)  
moveFocus undefined | boolean set focus to popup - default to not set focus  
offset number Offset from the parent (defaults to 4)  
position RelativePosition Direction (relative to the target) to which the popup is expanded (defaults to Bottom)  
repositionOnResize undefined | boolean If true the popup will remain open and will be repositioned when window resize events occur, default to false. Beta  
role "alert" | "alertdialog" | "dialog" Role - if not specified "dialog" is used  
showArrow boolean Show or hide the arrow (defaults to false)  
showShadow boolean Show or hide the box shadow (defaults to true)  
target | HTMLElement Target element to position popup  
top number Top position (absolute positioning - defaults to 0)  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
itemId undefined | string CommonProps Optional unique identifier for item.
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 20 June, 2023