SearchBoxProps Interface

Properties for SearchBox component

Extends

Methods

Name Description
onClear(): void Optional Listens for onClick event for Clear (x) icon  
onEnterPressed(): void Optional Listens for keypress  
onEscPressed(): void Optional Listens for keypress  
onValueChanged(value: string): void Triggered when the content of SearchBox is changed  

Properties

Name Type Description
initialValue undefined | string Value to set SearchBox to initially  
placeholder undefined | string Placeholder value to show in gray before anything is entered in  
valueChangedDelay undefined | number Frequency to poll for changes in value, in milliseconds  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
itemId undefined | string CommonProps Optional unique identifier for item.
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 20 June, 2023