SliderProps Interface

Properties for Slider component

Extends

Methods

Name Description
formatMax(value: number): string Optional Format the max display value  
formatMin(value: number): string Optional Format the min display value  
formatTick(tick: number): string Optional Format a tick mark value  
formatTooltip(value: number): string Optional Format a value for the tooltip  
getTickCount(): number Optional Function to get the tick count.  
getTickValues(): number[] Optional Function to get the tick values.  
onChange(values: undefined): void Optional Listens for value changes.  
onSlideEnd(values: undefined): void Optional No longer available use onChange.  
onSlideStart(values: undefined): void Optional No longer available use onUpdate.  
onUpdate(values: undefined): void Optional Listens for value updates.  

Properties

Name Type Description
disabled undefined | boolean Indicates whether the Slider is disabled.  
includeTicksInWidth undefined | boolean Indicates whether to compensate for the tick marks when determining the width.  
max number Maximum value  
maxImage undefined | ReactNode Image to show for max.  
min number Minimum value  
minImage undefined | ReactNode Image to show for min.  
mode number | () => number The interaction mode.  
reversed undefined | boolean Indicates whether the display of the Slider values is reversed.  
showMinMax undefined | boolean Indicates whether to show min & max values to the left & right of the Slider.  
showTickLabels undefined | boolean Indicates whether to show tick labels under the tick marks.  
showTicks undefined | boolean Indicates whether to show tick marks under the Slider.  
showTooltip undefined | boolean Indicates whether to show tooltip with the value.  
step undefined | number Step value.  
tooltipBelow undefined | boolean Indicates whether the tooltip should show below the Slider instead of above.  
values number[] Values to set Slider to initially  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
itemId undefined | string CommonProps Optional unique identifier for item.
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 20 June, 2023