ToggleProps Interface

Deprecated  in 3.0. Use ToggleSwitchProps in itwinui-react instead

Properties for Toggle component

Extends

Methods

Name Description
onBlur(event: FocusEvent<Element, Element>): any Optional Function called when the toggle loses focus  
onChange(checked: boolean): any Optional Function called when the toggle state is changed  

Properties

Name Type Description
buttonType undefined | ToggleButtonType Button type, either Primary or Blue (Blue is default). Deprecated  
disabled undefined | boolean Indicates whether the Toggle is disabled (default is false)  
isOn undefined | boolean Indicates whether the Toggle is "on" or "off" (default is false)  
large undefined | boolean Use larger size (default is false)  
ref undefined | Ref<HTMLInputElement> Provides ability to return reference to HTMLInputElement  
rounded undefined | boolean Show the toggle rounded or square (rounded is default)  
setFocus undefined | boolean Indicates whether to set focus to the input element  
showCheckmark undefined | boolean Show a check mark icon when the toggle is "on" (false is default)  
title undefined | string Tooltip text  

Inherited properties

Name Type Inherited from Description
className undefined | string CommonProps Custom CSS class name
itemId undefined | string CommonProps Optional unique identifier for item.
style undefined | CSSProperties CommonProps Custom CSS style properties

Defined in

Last Updated: 20 June, 2023