initFromExternalSourceAspects Method

Deprecated  in 3.x. call IModelTransformer.initialize instead, it does the same thing among other initialization

Initialize the source to target Element mapping from ExternalSourceAspects in the target iModel.

initFromExternalSourceAspects(args?: InitFromExternalSourceAspectsArgs): void | Promise<void>

note This method is called from all process* functions and should never need to be called directly.

note Passing an InitFromExternalSourceAspectsArgs is required when processing changes, to remap any elements that may have been deleted. You must await the returned promise as well in this case. The synchronous behavior has not changed but is deprecated and won't process everything.

Parameter Type Description
args InitFromExternalSourceAspectsArgs  

Returns - void | Promise<void>

Defined in

Last Updated: 20 June, 2023