processChanges Method

Export changes from the source iModel and import the transformed entities into the target iModel. Inserts, updates, and deletes are determined by inspecting the changeset(s).

processChanges(accessToken: string, startChangesetId?: string): Promise<void>

note To form a range of versions to process, set startChangesetId for the start (inclusive) of the desired range and open the source iModel as of the end (inclusive) of the desired range.

Parameter Type Description
accessToken string A valid access token string
startChangesetId string Include changes from this changeset up through and including the current changeset.
If this parameter is not provided, then just the current changeset will be exported.

Returns - Promise<void>

Defined in

Last Updated: 20 June, 2023