QuantityNumberInput Function

Beta  

The QuantityNumberInput component accepts input for quantity values. The quantity value is shown as a single numeric value and the quantity's "display" unit is shown next to the input control. The "display" unit is determined by the active unit system as defined by the QuantityFormatter. The control also display buttons to increment and decrement the "displayed" value. The value reported by via the onChange function is in "persistence" units that can be stored in the iModel.

QuantityNumberInput(props: QuantityNumberInputProps): | Element

Parameter Type Description
props QuantityNumberInputProps  

Returns - | Element

Defined in

Last Updated: 20 June, 2023