TimelineComponentProps Interface
TimelineComponentProps configure the timeline
Methods
Name | Description | |
---|---|---|
onChange(duration: number): void Optional | Callback with current duration value (as a fraction) | |
onJump(forward: boolean): void Optional | Callback triggered when backward/forward buttons are pressed | |
onPlayPause(playing: boolean): void Optional | Callback triggered when play/pause button is pressed | |
onSettingsChange(arg: PlaybackSettings): void Optional | Callback triggered when a setting is changed |
Properties
Name | Type | Description | |
---|---|---|---|
alwaysMinimized | undefined | boolean | Always display in miniMode with no expand menu (For future use. | |
appMenuItemOption | undefined | TimelineMenuItemOption | How to include the supplied app menu items in the Timeline Context Menu (prefix, append, replace) | |
appMenuItems | undefined | TimelineMenuItemProps[] | App-supplied speed entries in the Timeline Context Menu | |
componentId | undefined | string | ComponentId -- must be set to use TimelineComponentEvents | |
dateFormatOptions | undefined | DateFormatOptions | Options used to format date string. | |
endDate | undefined | Date | End date: end of the date range of a date-based timeline. | |
includeRepeat | undefined | boolean | Include the repeat option on the Timeline Context Menu | |
initialDuration | undefined | number | Initial value for the current duration (the location of the thumb) in milliseconds | |
markDate | undefined | TimelineDateMarkerProps | Display a marker on the timeline rail to indicate current date - will only work if starDate and endDate are defined | |
minimized | undefined | boolean | Show in minimized mode (For future use. | |
repeat | undefined | boolean | When playing, repeat indefinitely | |
showDuration | undefined | boolean | Show duration instead of time | |
startDate | undefined | Date | Start date: beginning of the date range of a date-based timeline. | |
timeFormatOptions | undefined | DateFormatOptions | Options used to format time string. | |
timeZoneOffset | undefined | number | Display date and time offset by the number of minutes specified. | |
totalDuration | number | Total duration: range of the timeline in milliseconds. |
Defined in
Last Updated: 20 June, 2023