CategoryDescription Namespace
Function
Name | Description |
---|---|
CategoryDescription.fromJSON | Deserialize CategoryDescription from JSON. |
CategoryDescription.listFromJSON | Deserialize a list of CategoryDescription from JSON. |
CategoryDescription.toJSON | Serialize given category to JSON |
Defined in
CategoryDescription Interface
A data structure that describes a Field category.
Properties
Name | Type | Description | |
---|---|---|---|
description | string | Extensive description | |
expand | boolean | Should this category be auto-expanded when it's displayed in the UI | |
label | string | Display label | |
name | string | Unique name | |
parent | undefined | CategoryDescription | Parent category description | |
priority | number | Priority. | |
renderer | undefined | RendererDescription | Custom renderer description |
Defined in
Last Updated: 20 June, 2023