Core

Common types used all across Presentation packages.

Classes

Name Description  
KeySet A class that holds multiple Key objects.  
PresentationError An error type thrown by Presentation APIs.  
RegisteredRuleset A ruleset that is registered in a ruleset manager.  
RulesetsFactory A factory class that can be used to create presentation rulesets targeted towards  

Constants

Name Description  
DEFAULT_KEYS_BATCH_SIZE Default (recommended) keyset batch size for cases when it needs to be sent  

Enumerations

Name Description  
PresentationCommonLoggerCategory Logger categories used by this package  
PresentationStatus Status codes used by Presentation APIs.  
VariableValueTypes Possible variable value types  

Global Functions

Name Description  
getInstancesCount Get total number of instances included in the supplied key set.  

Interfaces

Name Description  
BooleanRulesetVariable Data structure for representing boolean ruleset variables.  
BooleanRulesetVariableJSON JSON representation of BooleanRulesetVariable. Deprecated
ClassInfo Information about an ECClass  
ClassInfoJSON A serialized version of ClassInfo Deprecated
ClientDiagnostics Data structure with client diagnostics information. Beta
ClientDiagnosticsAttribute Data structure which contains client diagnostics options.  
ClientDiagnosticsOptions Data structure for client diagnostics options. Beta
CompressedClassInfoJSON A serialized and compressed version of ClassInfo  
ComputeSelectionRequestOptions Request options used for calculating selection based on given instance keys and selection scope.  
ContentDescriptorRequestOptions Request type for content descriptor requests.  
ContentInstanceKeysRequestOptions Request type for content instance keys' requests.  
ContentRequestOptions Request type for content requests.  
ContentSourcesRequestOptions Request type for content sources requests.  
Diagnostics Data structure for diagnostics information. Beta
DiagnosticsLogMessage Data structure for diagnostics log message information. Beta
DiagnosticsOptions Data structure for diagnostics options. Beta
DiagnosticsScopeLogs Data structure for diagnostics scope information. Beta
DisplayLabelRequestOptions Request type for label requests  
DisplayLabelsRequestOptions Request type for labels requests  
DistinctValuesRequestOptions Request type for distinct values' requests.  
EnumerationChoice A single choice in enumeration  
EnumerationInfo Enumeration information  
FilterByInstancePathsHierarchyRequestOptions Request type of filtering hierarchies by given ECInstance paths.  
FilterByTextHierarchyRequestOptions Request type of filtering hierarchies by given text.  
HierarchyCompareInfo Information about hierarchy modification / differences.  
HierarchyCompareInfoJSON JSON representation of HierarchyCompareInfo. Deprecated
HierarchyCompareOptions Data structure for comparing a hierarchy after ruleset or ruleset variable changes.  
HierarchyLevelDescriptorRequestOptions Params for hierarchy level descriptor requests. Beta
HierarchyRequestOptions Request type for hierarchy requests.  
Id64RulesetVariable Data structure for representing ID ruleset variables.  
Id64RulesetVariableJSON JSON representation of Id64RulesetVariable. Deprecated
Id64sRulesetVariable Data structure for representing ID array ruleset variables.  
Id64sRulesetVariableJSON JSON representation of Id64sRulesetVariable.  
InstanceFilterDefinition Definition of an instance filter that can be used to filter content or hierarchy levels. Beta
InstanceFilterRelatedInstancePath Partial definition of common attributes for InstanceFilterRelatedInstanceDefinition. Beta
InstanceFilterRelatedInstanceRelationshipAlias Partial definition of InstanceFilterRelatedInstanceDefinition for the case when referencing the relationship class. Beta
InstanceFilterRelatedInstanceTargetAlias Partial definition of InstanceFilterRelatedInstanceDefinition for the case when referencing the target class. Beta
InstanceKey A key that uniquely identifies an instance in an iModel  
InstanceKeyJSON A serialized version of InstanceKey Deprecated
IntRulesetVariable Data structure for representing int ruleset variables.  
IntRulesetVariableJSON JSON representation of IntRulesetVariable. Deprecated
IntsRulesetVariable Data structure for representing int array ruleset variables.  
IntsRulesetVariableJSON JSON representation of IntsRulesetVariable. Deprecated
KeySetJSON A data structure of serialized KeySet  
KindOfQuantityInfo Kind of quantity information  
MultiElementPropertiesRequestOptions Request type for multiple elements properties requests.  
NavigationPropertyInfo A data structure for storing navigation property information. Beta
NavigationPropertyInfoJSON A serialized version of NavigationPropertyInfo Beta
NodeDeletionInfo Information about node deletion.  
NodeDeletionInfoJSON JSON representation of NodeDeletionInfo. Deprecated
NodeInsertionInfo Information about node insertion.  
NodeInsertionInfoJSON JSON representation of NodeInsertionInfo. Deprecated
NodeUpdateInfo Information about node update.  
NodeUpdateInfoJSON JSON representation of NodeUpdateInfo. Deprecated
PagedResponse A structure for paged responses  
PageOptions Paging options  
PropertyInfo A structure that describes an ECProperty  
PropertyInfoJSON A serialized version of PropertyInfo  
RelatedClassInfo A structure that describes a related class and the properties of that relationship.  
RelatedClassInfoJSON A serialized version of RelatedClassInfo  
RequestOptions A generic request options type used for both hierarchy and content requests.  
RequestOptionsWithRuleset Options for requests that require presentation ruleset.  
RulesetVariableBase Base data structure for representing ruleset variables.  
RulesetVariableBaseJSON JSON representation of RulesetVariableBase.  
SelectionScopeRequestOptions Request options used for selection scope related requests  
SingleElementPropertiesRequestOptions Request type for single element properties requests.  
StringRulesetVariable Data structure for representing string ruleset variables.  
StringRulesetVariableJSON JSON representation of StringRulesetVariable. Deprecated
StrippedRelatedClassInfo Data structure that contains a subset of RelatedClassInfo required to  
ValuesDictionary A dictionary data structure.  

Namespaces

Name Description  
ClassInfo  
DiagnosticsLogEntry Functions related to diagnostics log entry. Beta
HierarchyCompareInfo  
InstanceKey  
Key  
NavigationPropertyInfo Contains utilities for working with objects of NavigationPropertyInfo type. Beta
PartialHierarchyModification  
PropertyInfo  
RelatedClassInfo  
RelatedClassInfoWithOptionalRelationship  
RelationshipPath  
RulesetVariable  

Type Aliases

Name Description  
ClassId Type of an ECClass ID.  
ClientDiagnosticsHandler  
ComputeDisplayValueCallback  
DiagnosticsLogEntry Data structure for diagnostics log entry. Beta
DiagnosticsLoggerSeverity Type of diagnostics logger severity. Beta
ElementPropertiesRequestOptions Request type for element properties requests  
InstanceFilterRelatedInstanceDefinition Related instance definition for accessing properties of a related instance in InstanceFilterDefinition.expression. Beta
InstanceId Type of an ECInstance ID.  
Key A single key that identifies something in an iTwin.js application  
Keys A type for multiple keys that identify something in iModel.js application  
Omit Create a type with T properties excluding properties listed in K.  
Paged A wrapper type that injects PageOptions into supplied type  
PartialBy Create a type from given type T and make specified properties optional.  
PartialHierarchyModification Information about a hierarchy change: insertion, deletion or node update.  
PartialHierarchyModificationJSON JSON representation of PartialHierarchyModification. Deprecated
PrimitivePropertyValue Value of a primitive property.  
Prioritized A wrapper type that injects priority into supplied type.  
RelatedClassInfoWithOptionalRelationship A structure that describes a relationship between source and target classes where  
RelatedClassInfoWithOptionalRelationshipJSON  
RelationshipPath A structure that describes a related class path.  
RelationshipPathJSON Serialized RelationshipPath  
RulesetVariable Data structure for representing ruleset variables.  
RulesetVariableJSON JSON representation of RulesetVariable.  
StrippedRelationshipPath Data structure that contains a subset of RelationshipPath required to  
Subtract Create a type with T properties excluding all properties in type K.  
VariableValue Union of all supported variable value types  
VariableValueJSON JSON representation of VariableValue  
WithCancelEvent A wrapper type that injects cancelEvent into supplied type.  

Last Updated: 20 June, 2023