ClassGroup Interface

Base class grouping allows grouping ECInstance nodes by their base class (as opposed to the hierarchy specifications' groupByClass attribute, which always groups by direct class).

see Base class grouping documentation section

Extends

Properties

Name Type Description
baseClass undefined | SingleSchemaClassSpecification Specification of the base ECClass to group by.  
createGroupForSingleItem undefined | boolean Specifies whether a grouping node should be created if there is only one item in that group.  
specType "Class" Used for serializing to JSON.  

Defined in

Last Updated: 20 June, 2023