RootNodeRule Interface

Root node rules are used to define nodes that are displayed at the root hierarchy level.

see Root node rule reference documentation page

Extends

Properties

Name Type Description
autoExpand undefined | boolean Tells the library to assign produced nodes a flag, indicating that they should be automatically expanded.  
ruleType "RootNodes" Used for serializing to JSON.  

Inherited properties

Name Type Inherited from Description
condition undefined | string NavigationRuleBase Defines a condition which needs to be met in order for the rule to be used.
customizationRules undefined | CustomizationRule[] NavigationRuleBase A list of customization rules that
onlyIfNotHandled undefined | boolean NavigationRuleBase Tells the library that the rule should only be handled if no other rule of the same type was handled previously (based on rule
priority undefined | number NavigationRuleBase Defines the order in which rules are handled, higher number means the rule is handled first.
requiredSchemas undefined | RequiredSchemaSpecification[] NavigationRuleBase A list of ECSchema requirements that need to be met for the rule to be used.
specifications undefined | ChildNodeSpecification[] NavigationRuleBase A list of hierarchy specifications that define what nodes are going to be returned.
stopFurtherProcessing undefined | boolean NavigationRuleBase Stop processing rules that have lower priority.
subConditions undefined | SubCondition[] NavigationRuleBase A list of sub-rules which share placement attributes and

Defined in

Last Updated: 20 June, 2023