IContentDataProvider Interface

Interface for all presentation-driven content providers.

Extends

Implemented by

Methods

Name Description
getContent(pageOptions?: PageOptions): Promise<undefined | Content> Get the content.  
getContentDescriptor(): Promise<undefined | Descriptor> Get the content descriptor.  
getContentSetSize(): Promise<number> Get the number of content records.  
getFieldByPropertyRecord(propertyRecord: PropertyRecord): Promise<undefined | Field> Get field that was used to create the given property record  

Inherited methods

Name Inherited from Description
dispose(): void IPresentationDataProvider Disposes of any resources owned by this object.

Properties

Name Type Description
displayType Readonly string Display type used to format content  
keys KeySet Keys defining what to request content for  
selectionInfo undefined | SelectionInfo Information about selection event that results in content change  

Inherited properties

Name Type Inherited from Description
imodel Readonly IModelConnection IPresentationDataProvider IModelConnection used by this data provider
rulesetId Readonly string IPresentationDataProvider Id of the ruleset used by this data provider

Defined in

Last Updated: 20 June, 2023