useHierarchyLevelFiltering Function

Beta  

Custom hook that creates callbacks for filtering hierarchy levels in the tree. Filtering works only with trees based on PresentationTreeDataProvider.

useHierarchyLevelFiltering(props: UseHierarchyLevelFilteringProps): { applyFilter: (node: TreeNodeItem, info: PresentationInstanceFilterInfo) => void, clearFilter: (node: TreeNodeItem) => void }

Parameter Type Description
props UseHierarchyLevelFilteringProps  

Returns - { applyFilter: (node: TreeNodeItem, info: PresentationInstanceFilterInfo) => void, clearFilter: (node: TreeNodeItem) => void }

Defined in

Last Updated: 20 June, 2023