UiDataProvider Class

UiDataProvider Abstract class that allows property values to be passed between hosting API and UI.

Extended by

Methods

Name Description
constructor(): UiDataProvider    
fireItemsReloadedEvent(): void Called to inform listeners that new properties are ready for display in UI.  
fireSyncPropertiesEvent(syncProperties: DialogPropertySyncItem[]): void Called to inform listener that the UiDataProvider has updated values for the UI  
processChangesInUi(_properties: DialogPropertyItem[]): PropertyChangeResult Called by UI to inform data provider of changes.  
supplyAvailableProperties(): DialogPropertyItem[] Used to pass properties between a tool and an explicity defined UI dialog.  
syncProperties(syncProperties: DialogPropertySyncItem[]): void Called to sync properties synchronously if a UiDataProvider is active for the UI  
validateProperty(_item: DialogPropertyItem): PropertyChangeResult Called by UI to validate a property value  

Properties

Name Type Description
onItemsReloadedEvent BeUiEvent<void>    
onSyncPropertiesChangeEvent SyncPropertiesChangeEvent Get Sync UI Control Properties Event  

Defined in

Last Updated: 15 March, 2024