ConditionalStringValue Class

Class used to return a string value. The string value is refreshed by using the specified function. The syncEventIds define one or more eventIds that would require the stringGetter function to be rerun.

Methods

Name Description
constructor(stringGetter: () => string, syncEventIds: string[], value?: string): ConditionalStringValue Constructor for ConditionalStringValue.  
refresh(): boolean Called to update the value by running the stringGetter  
getValue(conditionalValue: undefined | string | ConditionalStringValue): undefined | string Static helper function to get string from a ConditionalStringValue | string | undefined  
refreshValue(conditionalValue: undefined | string | ConditionalStringValue, eventIds: Set<string>): boolean Static helper function to process properties defined as type ConditionalStringValue | string | undefined  

Properties

Name Type Description
stringGetter Readonly () => string    
syncEventIds Readonly string[] An array of eventId that should be monitored to determine when to run the refresh method.  
value Accessor ReadOnly string The current boolean value of the conditional.  

Defined in

Last Updated: 16 April, 2024