FrameworkUiAdmin Class

Subclass of UiAdmin in @itwin/core-frontend to be used to initialize IModelApp.

This implementation uses themed react components that blends in AppUI look and feel.

await IModelApp.startup({
  uiAdmin: new FrameworkUiAdmin()
});

Extends

Methods

Name Description
constructor(): FrameworkUiAdmin    
closeDialog(dialogId: string): boolean Closes the Tool Settings Ui popup.  
closeToolSettingsPopup(): boolean Closes the Tool Settings Ui popup.  
getKeyins(): KeyinEntry[]   Deprecated  
hideCalculator(): boolean Hides the calculator. Deprecated  
hideCard(): boolean Hides the Card.  
hideHTMLElement(): boolean Hides the HTML Element. Deprecated  
hideInputEditor(): boolean Hides the input editor.  
hideKeyinPalette(): boolean Hides the Key-in Palette. Deprecated  
hideMenuButton(id: string): boolean Hides a menu button. Deprecated  
hideToolbar(): boolean Hides the toolbar. Deprecated  
openDialog(uiDataProvider: DialogLayoutDataProvider, title: string, isModal: boolean, id: string, optionalProps?: DialogProps): boolean Opens a Dialog and automatically populates it using the properties defined by the UiDataProvider.  
openToolSettingsPopup(dataProvider: DialogLayoutDataProvider, location: Readonly<WritableXAndY>, offset: Readonly<WritableXAndY>, onCancel: OnCancelFunc, relativePosition?: RelativePosition, anchorElement?: HTMLElement): boolean Opens a Tool Settings Ui popup at a particular location.  
setFocusToHome(): void Sets focus to Home Deprecated  
showAngleEditor(initialValue: number, location: Readonly<WritableXAndY>, onCommit: OnNumberCommitFunc, onCancel: OnCancelFunc, htmlElement?: HTMLElement): boolean Show an input editor for an angle value at a particular location. Deprecated  
showCalculator(initialValue: number, resultIcon: string, location: Readonly<WritableXAndY>, onOk: OnNumberCommitFunc, onCancel: OnCancelFunc, htmlElement?: HTMLElement): boolean Show a calculator at a particular location. Deprecated  
showCard(content: HTMLElement, title: undefined | string | PropertyRecord, toolbarProps: undefined | AbstractToolbarProps, location: Readonly<WritableXAndY>, offset: Readonly<WritableXAndY>, onItemExecuted: OnItemExecutedFunc, onCancel: OnCancelFunc, relativePosition?: RelativePosition, anchorElement?: HTMLElement): boolean Show a Card containing content, a title and a toolbar at a particular location.  
showContextMenu(items: AbstractMenuItemProps[], location: Readonly<WritableXAndY>, htmlElement?: HTMLElement): boolean Show a context menu at a particular location. Deprecated  
showHTMLElement(displayElement: HTMLElement, location: Readonly<WritableXAndY>, offset: Readonly<WritableXAndY>, onCancel: OnCancelFunc, relativePosition?: RelativePosition, anchorElement?: HTMLElement): boolean Show an HTML element at a particular location. Deprecated  
showHeightEditor(initialValue: number, location: Readonly<WritableXAndY>, onCommit: OnNumberCommitFunc, onCancel: OnCancelFunc, htmlElement?: HTMLElement): boolean Show an input editor for a height value at a particular location. Deprecated  
showInputEditor(initialValue: Value, propertyDescription: PropertyDescription, location: Readonly<WritableXAndY>, onCommit: OnValueCommitFunc, onCancel: OnCancelFunc, htmlElement?: HTMLElement): boolean Show an input editor for a primitive value at a particular location.  
showKeyinPalette(htmlElement?: HTMLElement): boolean Show the Key-in Palette to display key-in from all registered Tools. Deprecated  
showLengthEditor(initialValue: number, location: Readonly<WritableXAndY>, onCommit: OnNumberCommitFunc, onCancel: OnCancelFunc, htmlElement?: HTMLElement): boolean Show an input editor for a length value at a particular location. Deprecated  
showMenuButton(id: string, menuItemsProps: AbstractMenuItemProps[], location: Readonly<WritableXAndY>, htmlElement?: HTMLElement): boolean Show a menu button at a particular location. Deprecated  
showReactCard(content: ReactNode, title: undefined | string | PropertyRecord, toolbarProps: undefined | AbstractToolbarProps, location: Readonly<WritableXAndY>, offset: Readonly<WritableXAndY>, onItemExecuted: OnItemExecutedFunc, onCancel: OnCancelFunc, relativePosition?: RelativePosition, anchorElement?: HTMLElement): boolean Show a Card containing React-based content, a title and a toolbar at a particular location.  
showToolbar(toolbarProps: AbstractToolbarProps, location: Readonly<WritableXAndY>, offset: Readonly<WritableXAndY>, onItemExecuted: OnItemExecutedFunc, onCancel: OnCancelFunc, relativePosition?: RelativePosition, htmlElement?: HTMLElement): boolean Show a Toolbar at a particular location. Deprecated  

Properties

Name Type Description
cursorPosition Accessor ReadOnly Readonly<WritableXAndY> Gets the cursor X and Y position, which is mouseEvent.pageX and mouseEvent.pageY.  
isFocusOnHome Accessor ReadOnly boolean Determines if focus is set to Home  
localizedKeyinPreference Accessor KeyinFieldLocalization    

Defined in

Last Updated: 21 March, 2024