ContentLayoutDef Class

Content Layout Definition class.

Methods

Name Description
constructor(layoutProps: ContentLayoutProps): ContentLayoutDef    
fillLayoutContainer(contentNodes: ReactNode[], resizable: boolean): ReactNode Fill a layout container with React nodes for each content view  
getUsedContentIndexes(): number[] Gets the indexes of content views used in this Content Layout  
toJSON(): ContentLayoutProps Creates ContentLayoutProps for JSON purposes  

Properties

Name Type Description
description string Description of the layout.  
id string ID for this Content Layout  
rootSplit Accessor ReadOnly undefined | LayoutSplit    

Defined in

Last Updated: 21 March, 2024