ToolbarGroupItem Interface

Describes the data needed to insert a group button into a toolbar.

Extends

Properties

Name Type Description
icon Readonly IconSpec Name of icon WebFont entry or if specifying an imported SVG symbol use "webSvg:" prefix to imported symbol Id.  
items Readonly undefined children of the group  
label Readonly string | ConditionalStringValue label, shown as tool tip on group button or a group button label in a group panel.  
panelLabel Readonly string | ConditionalStringValue label shown as the title in at top of group panel.  
parentGroupItemId Readonly undefined | string Optional parent tool group to add the tool to.  

Inherited properties

Name Type Inherited from Description
badge Readonly undefined | BadgeType CommonToolbarItem Describes badge.
description Readonly string | ConditionalStringValue CommonToolbarItem Optional description
groupPriority Readonly undefined | number CommonToolbarItem Specifies the item's grouping value.
id Readonly string CommonToolbarItem Require uniqueId for the item.
isActive Readonly undefined | boolean CommonToolbarItem Defines if the item is active (shown with an active stripe/bar).
isDisabled Readonly boolean | ConditionalBooleanValue CommonToolbarItem Describes if the item is enabled or disabled.
isHidden Readonly boolean | ConditionalBooleanValue CommonToolbarItem Describes if the item is visible or hidden.
itemPriority Readonly number CommonToolbarItem Priority within a toolbar or group.

Defined in

Last Updated: 21 March, 2024