FrameworkToolAdmin Class

Subclass of ToolAdmin in @itwin/core-frontend to be used to initialize IModelApp.

Enable processing of shortcut keys registered to keyboardShortcuts when focus is set to Home.

await IModelApp.startup({ toolAdmin: new FrameworkToolAdmin() });

Extends

Methods

Name Description
constructor(): FrameworkToolAdmin    
processShortcutKey(e: KeyboardEvent, wentDown: boolean): Promise<boolean> Process shortcut key events  

Defined in

Last Updated: 29 April, 2025