initialize MethodStatic

Called by the application to initialize the UiFramework. Also initializes UIIModelComponents, UiComponents, UiCore.

initialize(store: undefined | Store<any, AnyAction>, frameworkStateKey?: string): Promise<void>

Parameter Type Description
store undefined | Store<any, AnyAction> The single Redux store created by the host application. If this is undefined then it is assumed that the StateManager is being used to provide the Redux store.
frameworkStateKey string The name of the key used by the app when adding the UiFramework state into the Redux store. If not defined "frameworkState" is assumed. This value is ignored if StateManager is being used. The StateManager use "frameworkState".

Returns - Promise<void>

Defined in

Last Updated: 05 April, 2024