UiComponents Class

Manages the localization service for the components-react package.

Methods

Name Description
constructor(): UiComponents    
initialize(localization: Localization): Promise<void> Static Registers the localization service namespace for UiComponents.  
terminate(): void Static Unregisters the UiComponents localization namespace  

Properties

Name Type Description
initialized Accessor StaticReadOnly boolean Determines if UiComponents has been initialized  
localizationNamespace Accessor StaticReadOnly string The internationalization service namespace.  

Defined in

Last Updated: 05 April, 2024