InformationPartitionElement Class

An abstract base class for elements that establishes a particular modeling perspective for its parent Subject. Instances are always sub-modeled by a specialization of Model of the appropriate modeling perspective.

@see iModel Information Hierarchy, Subject, Model

Extends

Extended by

Methods

Name Description
constructor(props: InformationPartitionElementProps, iModel: IModelDb): InformationPartitionElement Protected    
toJSON(): InformationPartitionElementProps Obtain the JSON representation of this Entity.  
createCode(iModel: IModelDb, parentSubjectId: string, codeValue: string): Code Static Create a code that can be used for any subclass of InformationPartitionElement.  

Inherited methods

Name Inherited from Description
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected InformationContentElement Collect the Ids of this element's references at this level of the class hierarchy.
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected InformationContentElement Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void InformationContentElement Delete this Element from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: boolean = true): void InformationContentElement Call a function for each property of this Entity.
InformationContentElement Get the class metadata for this element.
getDisplayLabel(): string InformationContentElement Get a display label for this Element.
getJsonProperty(nameSpace: string): any InformationContentElement Get a JSON property of this element, by namespace
getPredecessorIds(): Id64Set InformationContentElement Get the Ids of this element's references.
getReferenceIds(): EntityReferenceSet InformationContentElement Get the set of this entity's entity references, EntityReferenceSet.
getToolTipMessage(): string[] InformationContentElement Get a list of HTML strings that describe this Element for the tooltip.
getUserProperties(namespace: string): any InformationContentElement Get a set of JSON user properties by namespace
insert(): string InformationContentElement Insert this Element into the iModel.
removeUserProperties(nameSpace: string): void InformationContentElement Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(nameSpace: string, value: any): void InformationContentElement  
setUserProperties(nameSpace: string, value: any): void InformationContentElement Change a set of user JSON properties of this Element by namespace.
update(): void InformationContentElement Update this Element in the iModel.
is(otherClass: undefined): boolean Static InformationContentElement return whether this Entity class is a subclass of another Entity class
onAllInputsHandled(_id: string, _iModel: IModelDb): void ProtectedStatic InformationContentElement Called on an element in a graph after all of its inputs have been processed and before its outputs are processed.
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void ProtectedStatic InformationContentElement Called when a root element in a subgraph is changed and before its outputs are processed.
onChildAdd(_arg: OnChildElementPropsArg): void ProtectedStatic InformationContentElement Called when an existing element is about to be updated so that an instance of this class will become its new parent.
onChildAdded(_arg: OnChildElementIdArg): void ProtectedStatic InformationContentElement Called after an existing element has been updated so that an instance of this class is its new parent.
onChildDelete(_arg: OnChildElementIdArg): void ProtectedStatic InformationContentElement Called when an element with an instance of this class as its parent is about to be deleted.
onChildDeleted(_arg: OnChildElementIdArg): void ProtectedStatic InformationContentElement Called after an element with an instance of this class as its parent was successfully deleted.
onChildDrop(_arg: OnChildElementIdArg): void ProtectedStatic InformationContentElement Called when an element with an instance of this class as its parent is about to be updated change to a different parent.
onChildDropped(_arg: OnChildElementIdArg): void ProtectedStatic InformationContentElement Called after an element with an instance of this class as its previous parent was updated to have a new parent.
onChildInsert(_arg: OnChildElementPropsArg): void ProtectedStatic InformationContentElement Called when a new element with an instance of this class as its parent is about to be inserted.
onChildInserted(_arg: OnChildElementIdArg): void ProtectedStatic InformationContentElement Called after a new element with an instance of this class as its parent was inserted.
onChildUpdate(_arg: OnChildElementPropsArg): void ProtectedStatic InformationContentElement Called when an element with an instance of this class as its parent is about to be updated.
onChildUpdated(_arg: OnChildElementIdArg): void ProtectedStatic InformationContentElement Called after an element with an instance of this the class as its parent was updated.
onCloned(_context: IModelElementCloneContext, _sourceProps: ElementProps, _targetProps: ElementProps): void ProtectedStatic InformationContentElement Called during the iModel transformation process after an Element from the source iModel was cloned for the target iModel.
onDelete(arg: OnElementIdArg): void ProtectedStatic InformationContentElement Called before an Element is deleted.
onDeleted(_arg: OnElementIdArg): void ProtectedStatic InformationContentElement Called after an Element was deleted.
onInsert(arg: OnElementPropsArg): void ProtectedStatic InformationContentElement Called before a new Element is inserted.
onInserted(arg: OnElementIdArg): void ProtectedStatic InformationContentElement Called after a new Element was inserted.
onSubModelDelete(_arg: OnSubModelIdArg): void ProtectedStatic InformationContentElement Called when a sub-model of an instance of this class is being deleted.
onSubModelDeleted(_arg: OnSubModelIdArg): void ProtectedStatic InformationContentElement Called after a sub-model of an instance of this class was deleted.
onSubModelInsert(_arg: OnSubModelPropsArg): void ProtectedStatic InformationContentElement Called when an instance of this class is being sub-modeled by a new Model.
onSubModelInserted(_arg: OnSubModelIdArg): void ProtectedStatic InformationContentElement Called after an instance of this class was sub-modeled by a new Model.
onUpdate(arg: OnElementPropsArg): void ProtectedStatic InformationContentElement Called before an Element is updated.
onUpdated(_arg: OnElementIdArg): void ProtectedStatic InformationContentElement Called after an Element was updated.

Properties

Name Type Description
description undefined | string A human-readable string describing the intent of the partition.  

Inherited properties

Name Type Inherited from Description
classFullName Accessor ReadOnly string InformationContentElement Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor StaticReadOnly string InformationContentElement Get the full BIS class name of this Entity in the form "schema:class"
className Accessor ReadOnly string InformationContentElement The name of the BIS class associated with this class.
code Code InformationContentElement The Code for this element
federationGuid undefined | string InformationContentElement A FederationGuid assigned to this element by some other federated database
id string InformationContentElement The Id of this Entity.
iModel IModelDb InformationContentElement The IModelDb that contains this Entity
isInstanceOfEntity Readonly "true" InformationContentElement An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
jsonProperties Readonly { T } InformationContentElement Optional json properties of this element.
model Readonly string InformationContentElement The ModelId of the Model containing this element
parent undefined | RelatedElement InformationContentElement The parent element, if present, of this element.
requiredReferenceKeys StaticReadonly undefined InformationContentElement A required reference is an element that had to be inserted before this element could have been inserted.
schema Static undefined InformationContentElement The Schema that defines this class.
schemaName Accessor ReadOnly string InformationContentElement The name of the BIS Schema that defines this class
userLabel undefined | string InformationContentElement A user-assigned label for this element.

Defined in

Last Updated: 15 March, 2024