An information element that links to a repository.

Extends

Methods

Name Description
constructor(props: RepositoryLinkProps, iModel: IModelDb): RepositoryLink Protected    
toJSON(): RepositoryLinkProps Obtain the JSON representation of this Entity.  

Inherited methods

Name Inherited from Description
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected UrlLink Collect the Ids of this element's references at this level of the class hierarchy.
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected UrlLink Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void UrlLink Delete this Element from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: boolean = true): void UrlLink Call a function for each property of this Entity.
UrlLink Get the class metadata for this element.
getDisplayLabel(): string UrlLink Get a display label for this Element.
getJsonProperty(nameSpace: string): any UrlLink Get a JSON property of this element, by namespace
getPredecessorIds(): Id64Set UrlLink Get the Ids of this element's references.
getReferenceIds(): EntityReferenceSet UrlLink Get the set of this entity's entity references, EntityReferenceSet.
getToolTipMessage(): string[] UrlLink Get a list of HTML strings that describe this Element for the tooltip.
getUserProperties(namespace: string): any UrlLink Get a set of JSON user properties by namespace
insert(): string UrlLink Insert this Element into the iModel.
removeUserProperties(nameSpace: string): void UrlLink Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(nameSpace: string, value: any): void UrlLink  
setUserProperties(nameSpace: string, value: any): void UrlLink Change a set of user JSON properties of this Element by namespace.
update(): void UrlLink Update this Element in the iModel.
createCode(iModel: IModelDb, scopeModelId: string, codeValue: string): Code Static UrlLink Create a Code for a LinkElement given a name that is meant to be unique within the scope of the specified Model.
is(otherClass: undefined): boolean Static UrlLink return whether this Entity class is a subclass of another Entity class
onAllInputsHandled(_id: string, _iModel: IModelDb): void ProtectedStatic UrlLink Called on an element in a graph after all of its inputs have been processed and before its outputs are processed.
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void ProtectedStatic UrlLink Called when a root element in a subgraph is changed and before its outputs are processed.
onChildAdd(_arg: OnChildElementPropsArg): void ProtectedStatic UrlLink Called when an existing element is about to be updated so that an instance of this class will become its new parent.
onChildAdded(_arg: OnChildElementIdArg): void ProtectedStatic UrlLink Called after an existing element has been updated so that an instance of this class is its new parent.
onChildDelete(_arg: OnChildElementIdArg): void ProtectedStatic UrlLink Called when an element with an instance of this class as its parent is about to be deleted.
onChildDeleted(_arg: OnChildElementIdArg): void ProtectedStatic UrlLink Called after an element with an instance of this class as its parent was successfully deleted.
onChildDrop(_arg: OnChildElementIdArg): void ProtectedStatic UrlLink Called when an element with an instance of this class as its parent is about to be updated change to a different parent.
onChildDropped(_arg: OnChildElementIdArg): void ProtectedStatic UrlLink Called after an element with an instance of this class as its previous parent was updated to have a new parent.
onChildInsert(_arg: OnChildElementPropsArg): void ProtectedStatic UrlLink Called when a new element with an instance of this class as its parent is about to be inserted.
onChildInserted(_arg: OnChildElementIdArg): void ProtectedStatic UrlLink Called after a new element with an instance of this class as its parent was inserted.
onChildUpdate(_arg: OnChildElementPropsArg): void ProtectedStatic UrlLink Called when an element with an instance of this class as its parent is about to be updated.
onChildUpdated(_arg: OnChildElementIdArg): void ProtectedStatic UrlLink Called after an element with an instance of this the class as its parent was updated.
onCloned(_context: IModelElementCloneContext, _sourceProps: ElementProps, _targetProps: ElementProps): void ProtectedStatic UrlLink Called during the iModel transformation process after an Element from the source iModel was cloned for the target iModel.
onDelete(arg: OnElementIdArg): void ProtectedStatic UrlLink Called before an Element is deleted.
onDeleted(_arg: OnElementIdArg): void ProtectedStatic UrlLink Called after an Element was deleted.
onInsert(arg: OnElementPropsArg): void ProtectedStatic UrlLink Called before a new Element is inserted.
onInserted(arg: OnElementIdArg): void ProtectedStatic UrlLink Called after a new Element was inserted.
onSubModelDelete(_arg: OnSubModelIdArg): void ProtectedStatic UrlLink Called when a sub-model of an instance of this class is being deleted.
onSubModelDeleted(_arg: OnSubModelIdArg): void ProtectedStatic UrlLink Called after a sub-model of an instance of this class was deleted.
onSubModelInsert(_arg: OnSubModelPropsArg): void ProtectedStatic UrlLink Called when an instance of this class is being sub-modeled by a new Model.
onSubModelInserted(_arg: OnSubModelIdArg): void ProtectedStatic UrlLink Called after an instance of this class was sub-modeled by a new Model.
onUpdate(arg: OnElementPropsArg): void ProtectedStatic UrlLink Called before an Element is updated.
onUpdated(_arg: OnElementIdArg): void ProtectedStatic UrlLink Called after an Element was updated.

Properties

Name Type Description
format undefined | string    
repositoryGuid undefined | string    

Inherited properties

Name Type Inherited from Description
classFullName Accessor ReadOnly string UrlLink Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor StaticReadOnly string UrlLink Get the full BIS class name of this Entity in the form "schema:class"
className Accessor ReadOnly string UrlLink The name of the BIS class associated with this class.
code Code UrlLink The Code for this element
description undefined | string UrlLink  
federationGuid undefined | string UrlLink A FederationGuid assigned to this element by some other federated database
id string UrlLink The Id of this Entity.
iModel IModelDb UrlLink The IModelDb that contains this Entity
isInstanceOfEntity Readonly "true" UrlLink An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
jsonProperties Readonly { T } UrlLink Optional json properties of this element.
model Readonly string UrlLink The ModelId of the Model containing this element
parent undefined | RelatedElement UrlLink The parent element, if present, of this element.
requiredReferenceKeys StaticReadonly undefined UrlLink A required reference is an element that had to be inserted before this element could have been inserted.
schema Static undefined UrlLink The Schema that defines this class.
schemaName Accessor ReadOnly string UrlLink The name of the BIS Schema that defines this class
url undefined | string UrlLink  
userLabel undefined | string UrlLink A user-assigned label for this element.

Defined in

Last Updated: 15 March, 2024