SpatialLocationType Class

Defines a set of properties (the type) that can be associated with a spatial location.

Extends

Methods

Name Description
constructor(props: TypeDefinitionElementProps, iModel: IModelDb): SpatialLocationType Protected    
createCode(iModel: IModelDb, scopeModelId: string, codeValue: string): Code Static Create a Code for a SpatialLocationType element given a name that is meant to be unique within the scope of the specified DefinitionModel.  

Inherited methods

Name Inherited from Description
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected TypeDefinitionElement Collect the Ids of this element's references at this level of the class hierarchy.
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected TypeDefinitionElement Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void TypeDefinitionElement Delete this Element from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: boolean = true): void TypeDefinitionElement Call a function for each property of this Entity.
TypeDefinitionElement Get the class metadata for this element.
getDisplayLabel(): string TypeDefinitionElement Get a display label for this Element.
getJsonProperty(nameSpace: string): any TypeDefinitionElement Get a JSON property of this element, by namespace
getPredecessorIds(): Id64Set TypeDefinitionElement Get the Ids of this element's references.
getReferenceIds(): EntityReferenceSet TypeDefinitionElement Get the set of this entity's entity references, EntityReferenceSet.
getToolTipMessage(): string[] TypeDefinitionElement Get a list of HTML strings that describe this Element for the tooltip.
getUserProperties(namespace: string): any TypeDefinitionElement Get a set of JSON user properties by namespace
insert(): string TypeDefinitionElement Insert this Element into the iModel.
removeUserProperties(nameSpace: string): void TypeDefinitionElement Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(nameSpace: string, value: any): void TypeDefinitionElement  
setUserProperties(nameSpace: string, value: any): void TypeDefinitionElement Change a set of user JSON properties of this Element by namespace.
toJSON(): DefinitionElementProps TypeDefinitionElement Obtain the JSON representation of this Entity.
update(): void TypeDefinitionElement Update this Element in the iModel.
is(otherClass: undefined): boolean Static TypeDefinitionElement return whether this Entity class is a subclass of another Entity class
onAllInputsHandled(_id: string, _iModel: IModelDb): void ProtectedStatic TypeDefinitionElement Called on an element in a graph after all of its inputs have been processed and before its outputs are processed.
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void ProtectedStatic TypeDefinitionElement Called when a root element in a subgraph is changed and before its outputs are processed.
onChildAdd(_arg: OnChildElementPropsArg): void ProtectedStatic TypeDefinitionElement Called when an existing element is about to be updated so that an instance of this class will become its new parent.
onChildAdded(_arg: OnChildElementIdArg): void ProtectedStatic TypeDefinitionElement Called after an existing element has been updated so that an instance of this class is its new parent.
onChildDelete(_arg: OnChildElementIdArg): void ProtectedStatic TypeDefinitionElement Called when an element with an instance of this class as its parent is about to be deleted.
onChildDeleted(_arg: OnChildElementIdArg): void ProtectedStatic TypeDefinitionElement Called after an element with an instance of this class as its parent was successfully deleted.
onChildDrop(_arg: OnChildElementIdArg): void ProtectedStatic TypeDefinitionElement Called when an element with an instance of this class as its parent is about to be updated change to a different parent.
onChildDropped(_arg: OnChildElementIdArg): void ProtectedStatic TypeDefinitionElement Called after an element with an instance of this class as its previous parent was updated to have a new parent.
onChildInsert(_arg: OnChildElementPropsArg): void ProtectedStatic TypeDefinitionElement Called when a new element with an instance of this class as its parent is about to be inserted.
onChildInserted(_arg: OnChildElementIdArg): void ProtectedStatic TypeDefinitionElement Called after a new element with an instance of this class as its parent was inserted.
onChildUpdate(_arg: OnChildElementPropsArg): void ProtectedStatic TypeDefinitionElement Called when an element with an instance of this class as its parent is about to be updated.
onChildUpdated(_arg: OnChildElementIdArg): void ProtectedStatic TypeDefinitionElement Called after an element with an instance of this the class as its parent was updated.
onCloned(_context: IModelElementCloneContext, _sourceProps: ElementProps, _targetProps: ElementProps): void ProtectedStatic TypeDefinitionElement Called during the iModel transformation process after an Element from the source iModel was cloned for the target iModel.
onDelete(arg: OnElementIdArg): void ProtectedStatic TypeDefinitionElement Called before an Element is deleted.
onDeleted(_arg: OnElementIdArg): void ProtectedStatic TypeDefinitionElement Called after an Element was deleted.
onInsert(arg: OnElementPropsArg): void ProtectedStatic TypeDefinitionElement Called before a new Element is inserted.
onInserted(arg: OnElementIdArg): void ProtectedStatic TypeDefinitionElement Called after a new Element was inserted.
onSubModelDelete(_arg: OnSubModelIdArg): void ProtectedStatic TypeDefinitionElement Called when a sub-model of an instance of this class is being deleted.
onSubModelDeleted(_arg: OnSubModelIdArg): void ProtectedStatic TypeDefinitionElement Called after a sub-model of an instance of this class was deleted.
onSubModelInsert(_arg: OnSubModelPropsArg): void ProtectedStatic TypeDefinitionElement Called when an instance of this class is being sub-modeled by a new Model.
onSubModelInserted(_arg: OnSubModelIdArg): void ProtectedStatic TypeDefinitionElement Called after an instance of this class was sub-modeled by a new Model.
onUpdate(arg: OnElementPropsArg): void ProtectedStatic TypeDefinitionElement Called before an Element is updated.
onUpdated(_arg: OnElementIdArg): void ProtectedStatic TypeDefinitionElement Called after an Element was updated.

Inherited properties

Name Type Inherited from Description
classFullName Accessor ReadOnly string TypeDefinitionElement Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor StaticReadOnly string TypeDefinitionElement Get the full BIS class name of this Entity in the form "schema:class"
className Accessor ReadOnly string TypeDefinitionElement The name of the BIS class associated with this class.
code Code TypeDefinitionElement The Code for this element
federationGuid undefined | string TypeDefinitionElement A FederationGuid assigned to this element by some other federated database
id string TypeDefinitionElement The Id of this Entity.
iModel IModelDb TypeDefinitionElement The IModelDb that contains this Entity
isInstanceOfEntity Readonly "true" TypeDefinitionElement An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
isPrivate boolean TypeDefinitionElement If true, don't show this DefinitionElement in user interface lists.
jsonProperties Readonly { T } TypeDefinitionElement Optional json properties of this element.
model Readonly string TypeDefinitionElement The ModelId of the Model containing this element
parent undefined | RelatedElement TypeDefinitionElement The parent element, if present, of this element.
recipe undefined | RelatedElement TypeDefinitionElement  
requiredReferenceKeys StaticReadonly undefined TypeDefinitionElement A required reference is an element that had to be inserted before this element could have been inserted.
schema Static undefined TypeDefinitionElement The Schema that defines this class.
schemaName Accessor ReadOnly string TypeDefinitionElement The name of the BIS Schema that defines this class
userLabel undefined | string TypeDefinitionElement A user-assigned label for this element.

Defined in

Last Updated: 15 March, 2024