TemplateRecipe3d Class

A TemplateRecipe3d is a DefinitionElement that has a sub-model that contains the 3d template elements.

Extends

Methods

Name Description
constructor(props: ElementProps, iModel: IModelDb): TemplateRecipe3d Protected    
create(iModelDb: IModelDb, definitionModelId: string, name: string, isPrivate?: boolean): TemplateRecipe3d Static Create a TemplateRecipe3d  
createCode(iModelDb: IModelDb, definitionModelId: string, codeValue: string): Code Static Create a Code for a TemplateRecipe3d given a name that is meant to be unique within the scope of its Model.  
insert(iModelDb: IModelDb, definitionModelId: string, name: string, isPrivate?: boolean): string Static Insert a TemplateRecipe3d and a PhysicalModel (sub-model) that will contain the 3d template elements.  

Inherited methods

Name Inherited from Description
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected RecipeDefinitionElement Collect the Ids of this element's references at this level of the class hierarchy.
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected RecipeDefinitionElement Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void RecipeDefinitionElement Delete this Element from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: boolean = true): void RecipeDefinitionElement Call a function for each property of this Entity.
RecipeDefinitionElement Get the class metadata for this element.
getDisplayLabel(): string RecipeDefinitionElement Get a display label for this Element.
getJsonProperty(nameSpace: string): any RecipeDefinitionElement Get a JSON property of this element, by namespace
getPredecessorIds(): Id64Set RecipeDefinitionElement Get the Ids of this element's references.
getReferenceIds(): EntityReferenceSet RecipeDefinitionElement Get the set of this entity's entity references, EntityReferenceSet.
getToolTipMessage(): string[] RecipeDefinitionElement Get a list of HTML strings that describe this Element for the tooltip.
getUserProperties(namespace: string): any RecipeDefinitionElement Get a set of JSON user properties by namespace
insert(): string RecipeDefinitionElement Insert this Element into the iModel.
removeUserProperties(nameSpace: string): void RecipeDefinitionElement Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(nameSpace: string, value: any): void RecipeDefinitionElement  
setUserProperties(nameSpace: string, value: any): void RecipeDefinitionElement Change a set of user JSON properties of this Element by namespace.
toJSON(): DefinitionElementProps RecipeDefinitionElement Obtain the JSON representation of this Entity.
update(): void RecipeDefinitionElement Update this Element in the iModel.
is(otherClass: undefined): boolean Static RecipeDefinitionElement return whether this Entity class is a subclass of another Entity class
onAllInputsHandled(_id: string, _iModel: IModelDb): void ProtectedStatic RecipeDefinitionElement Called on an element in a graph after all of its inputs have been processed and before its outputs are processed.
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void ProtectedStatic RecipeDefinitionElement Called when a root element in a subgraph is changed and before its outputs are processed.
onChildAdd(_arg: OnChildElementPropsArg): void ProtectedStatic RecipeDefinitionElement Called when an existing element is about to be updated so that an instance of this class will become its new parent.
onChildAdded(_arg: OnChildElementIdArg): void ProtectedStatic RecipeDefinitionElement Called after an existing element has been updated so that an instance of this class is its new parent.
onChildDelete(_arg: OnChildElementIdArg): void ProtectedStatic RecipeDefinitionElement Called when an element with an instance of this class as its parent is about to be deleted.
onChildDeleted(_arg: OnChildElementIdArg): void ProtectedStatic RecipeDefinitionElement Called after an element with an instance of this class as its parent was successfully deleted.
onChildDrop(_arg: OnChildElementIdArg): void ProtectedStatic RecipeDefinitionElement Called when an element with an instance of this class as its parent is about to be updated change to a different parent.
onChildDropped(_arg: OnChildElementIdArg): void ProtectedStatic RecipeDefinitionElement Called after an element with an instance of this class as its previous parent was updated to have a new parent.
onChildInsert(_arg: OnChildElementPropsArg): void ProtectedStatic RecipeDefinitionElement Called when a new element with an instance of this class as its parent is about to be inserted.
onChildInserted(_arg: OnChildElementIdArg): void ProtectedStatic RecipeDefinitionElement Called after a new element with an instance of this class as its parent was inserted.
onChildUpdate(_arg: OnChildElementPropsArg): void ProtectedStatic RecipeDefinitionElement Called when an element with an instance of this class as its parent is about to be updated.
onChildUpdated(_arg: OnChildElementIdArg): void ProtectedStatic RecipeDefinitionElement Called after an element with an instance of this the class as its parent was updated.
onCloned(_context: IModelElementCloneContext, _sourceProps: ElementProps, _targetProps: ElementProps): void ProtectedStatic RecipeDefinitionElement Called during the iModel transformation process after an Element from the source iModel was cloned for the target iModel.
onDelete(arg: OnElementIdArg): void ProtectedStatic RecipeDefinitionElement Called before an Element is deleted.
onDeleted(_arg: OnElementIdArg): void ProtectedStatic RecipeDefinitionElement Called after an Element was deleted.
onInsert(arg: OnElementPropsArg): void ProtectedStatic RecipeDefinitionElement Called before a new Element is inserted.
onInserted(arg: OnElementIdArg): void ProtectedStatic RecipeDefinitionElement Called after a new Element was inserted.
onSubModelDelete(_arg: OnSubModelIdArg): void ProtectedStatic RecipeDefinitionElement Called when a sub-model of an instance of this class is being deleted.
onSubModelDeleted(_arg: OnSubModelIdArg): void ProtectedStatic RecipeDefinitionElement Called after a sub-model of an instance of this class was deleted.
onSubModelInsert(_arg: OnSubModelPropsArg): void ProtectedStatic RecipeDefinitionElement Called when an instance of this class is being sub-modeled by a new Model.
onSubModelInserted(_arg: OnSubModelIdArg): void ProtectedStatic RecipeDefinitionElement Called after an instance of this class was sub-modeled by a new Model.
onUpdate(arg: OnElementPropsArg): void ProtectedStatic RecipeDefinitionElement Called before an Element is updated.
onUpdated(_arg: OnElementIdArg): void ProtectedStatic RecipeDefinitionElement Called after an Element was updated.

Inherited properties

Name Type Inherited from Description
classFullName Accessor ReadOnly string RecipeDefinitionElement Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor StaticReadOnly string RecipeDefinitionElement Get the full BIS class name of this Entity in the form "schema:class"
className Accessor ReadOnly string RecipeDefinitionElement The name of the BIS class associated with this class.
code Code RecipeDefinitionElement The Code for this element
federationGuid undefined | string RecipeDefinitionElement A FederationGuid assigned to this element by some other federated database
id string RecipeDefinitionElement The Id of this Entity.
iModel IModelDb RecipeDefinitionElement The IModelDb that contains this Entity
isInstanceOfEntity Readonly "true" RecipeDefinitionElement An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
isPrivate boolean RecipeDefinitionElement If true, don't show this DefinitionElement in user interface lists.
jsonProperties Readonly { T } RecipeDefinitionElement Optional json properties of this element.
model Readonly string RecipeDefinitionElement The ModelId of the Model containing this element
parent undefined | RelatedElement RecipeDefinitionElement The parent element, if present, of this element.
requiredReferenceKeys StaticReadonly undefined RecipeDefinitionElement A required reference is an element that had to be inserted before this element could have been inserted.
schema Static undefined RecipeDefinitionElement The Schema that defines this class.
schemaName Accessor ReadOnly string RecipeDefinitionElement The name of the BIS Schema that defines this class
userLabel undefined | string RecipeDefinitionElement A user-assigned label for this element.

Defined in

Last Updated: 16 April, 2024