LockConflict Class

Exception thrown if lock cannot be acquired.

Extends

Methods

Name Description
constructor(briefcaseId: number, briefcaseAlias: string, msg: "shared lock is held" | "exclusive lock is already held"): LockConflict    

Inherited methods

Name Inherited from Description
_initName(): string Protected IModelError This function returns the name of each error status.
IModelError get the meta data associated with this BentleyError, if any.
getErrorMessage(error: unknown): string Static IModelError Use run-time type checking to safely get a useful string summary of an unknown error value, or "" if none exists.
IModelError Use run-time type checking to safely get the metadata with an unknown error value, if possible.
getErrorProps(error: unknown): ErrorProps Static IModelError Returns a new ErrorProps object representing an unknown error value.
getErrorStack(error: unknown): undefined | string Static IModelError Use run-time type checking to safely get the call stack of an unknown error value, if possible.
IModelError get the metadata object associated with an ExceptionMetaData, if any.

Properties

Name Type Description
briefcaseAlias Readonly string Alias of Briefcase holding lock  
briefcaseId Readonly number Id of Briefcase holding lock  

Inherited properties

Name Type Inherited from Description
errorNumber number IModelError  
boolean IModelError Returns true if this BentleyError includes (optional) metadata.

Defined in

Last Updated: 15 March, 2024