GeometricModel2d Class

A container for persisting 2d geometric elements.

Extends

Extended by

Methods

Name Description
constructor(props: GeometricModel2dProps, iModel: IModelDb): GeometricModel2d Protected    
toJSON(): GeometricModel2dProps Obtain the JSON representation of this Entity.  

Inherited methods

Name Inherited from Description
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected GeometricModel Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void GeometricModel Delete this Model from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: boolean = true): void GeometricModel Call a function for each property of this Entity.
getJsonProperty(name: string): any GeometricModel  
getReferenceIds(): EntityReferenceSet GeometricModel Get the set of this entity's entity references, EntityReferenceSet.
getUserProperties(namespace: string): any GeometricModel Get a set of JSON user properties by namespace
insert(): string GeometricModel Insert this Model in the iModel
queryExtents(): Range3d GeometricModel Query for the union of the extents of the elements contained by this model.
queryRange(): Promise<Range3d> GeometricModel Query for the union of the extents of all elements contained within this model.
removeUserProperties(nameSpace: string): void GeometricModel Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(name: string, value: any): void GeometricModel  
setUserProperties(nameSpace: string, value: any): void GeometricModel Change a set of user JSON properties of this Element by namespace.
update(): void GeometricModel Update this Model in the iModel.
is(otherClass: undefined): boolean Static GeometricModel return whether this Entity class is a subclass of another Entity class
onDelete(arg: OnModelIdArg): void ProtectedStatic GeometricModel Called before a Model is deleted.
onDeleteElement(_arg: OnElementInModelIdArg): void ProtectedStatic GeometricModel Called when an Element in an instance of a Model of this class is about to be deleted.
onDeleted(_arg: OnModelIdArg): void ProtectedStatic GeometricModel Called after a Model was deleted.
onDeletedElement(_arg: OnElementInModelIdArg): void ProtectedStatic GeometricModel Called after an Element in an instance of a Model of this class has been deleted.
onInsert(arg: OnModelPropsArg): void ProtectedStatic GeometricModel Called before a new Model is inserted.
onInsertElement(_arg: OnElementInModelPropsArg): void ProtectedStatic GeometricModel Called before a prospective Element is to be inserted into an instance of a Model of this class.
onInserted(_arg: OnModelIdArg): void ProtectedStatic GeometricModel Called after a new Model is inserted.
onInsertedElement(_arg: OnElementInModelIdArg): void ProtectedStatic GeometricModel Called after an Element has been inserted into an instance of a Model of this class.
onUpdate(arg: OnModelPropsArg): void ProtectedStatic GeometricModel Called before a Model is updated.
onUpdateElement(_arg: OnElementInModelPropsArg): void ProtectedStatic GeometricModel Called when an Element in an instance of a Model of this class is about to be updated.
onUpdated(_arg: OnModelIdArg): void ProtectedStatic GeometricModel Called after a Model is updated.
onUpdatedElement(_arg: OnElementInModelIdArg): void ProtectedStatic GeometricModel Called after an Element in an instance of a Model of this class has been updated.

Properties

Name Type Description
globalOrigin undefined | Point2d The actual coordinates of (0,0) in modeling coordinates.  

Inherited properties

Name Type Inherited from Description
classFullName Accessor ReadOnly string GeometricModel Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor StaticReadOnly string GeometricModel Get the full BIS class name of this Entity in the form "schema:class"
className Accessor ReadOnly string GeometricModel The name of the BIS class associated with this class.
geometryGuid undefined | string GeometricModel  
id string GeometricModel The Id of this Entity.
iModel IModelDb GeometricModel The IModelDb that contains this Entity
isInstanceOfEntity Readonly "true" GeometricModel An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
isPrivate boolean GeometricModel  
isTemplate boolean GeometricModel  
jsonProperties Readonly { T } GeometricModel  
modeledElement Readonly RelatedElement GeometricModel  
name Readonly string GeometricModel  
parentModel Readonly string GeometricModel  
schema Static undefined GeometricModel The Schema that defines this class.
schemaName Accessor ReadOnly string GeometricModel The name of the BIS Schema that defines this class

Defined in

Last Updated: 16 April, 2024