LinkModel Class

A container for persisting link elements.

@see LinkPartition

Extends

Methods

Name Description
constructor(props: ModelProps, iModel: IModelDb): LinkModel Protected    

Inherited methods

Name Inherited from Description
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected InformationModel Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void InformationModel Delete this Model from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: boolean = true): void InformationModel Call a function for each property of this Entity.
getJsonProperty(name: string): any InformationModel  
getReferenceIds(): EntityReferenceSet InformationModel Get the set of this entity's entity references, EntityReferenceSet.
getUserProperties(namespace: string): any InformationModel Get a set of JSON user properties by namespace
insert(): string InformationModel Insert this Model in the iModel
removeUserProperties(nameSpace: string): void InformationModel Remove a set of JSON user properties, specified by namespace, from this Element
setJsonProperty(name: string, value: any): void InformationModel  
setUserProperties(nameSpace: string, value: any): void InformationModel Change a set of user JSON properties of this Element by namespace.
toJSON(): ModelProps InformationModel Obtain the JSON representation of this Entity.
update(): void InformationModel Update this Model in the iModel.
is(otherClass: undefined): boolean Static InformationModel return whether this Entity class is a subclass of another Entity class
onDelete(arg: OnModelIdArg): void ProtectedStatic InformationModel Called before a Model is deleted.
onDeleteElement(_arg: OnElementInModelIdArg): void ProtectedStatic InformationModel Called when an Element in an instance of a Model of this class is about to be deleted.
onDeleted(_arg: OnModelIdArg): void ProtectedStatic InformationModel Called after a Model was deleted.
onDeletedElement(_arg: OnElementInModelIdArg): void ProtectedStatic InformationModel Called after an Element in an instance of a Model of this class has been deleted.
onInsert(arg: OnModelPropsArg): void ProtectedStatic InformationModel Called before a new Model is inserted.
onInsertElement(_arg: OnElementInModelPropsArg): void ProtectedStatic InformationModel Called before a prospective Element is to be inserted into an instance of a Model of this class.
onInserted(_arg: OnModelIdArg): void ProtectedStatic InformationModel Called after a new Model is inserted.
onInsertedElement(_arg: OnElementInModelIdArg): void ProtectedStatic InformationModel Called after an Element has been inserted into an instance of a Model of this class.
onUpdate(arg: OnModelPropsArg): void ProtectedStatic InformationModel Called before a Model is updated.
onUpdateElement(_arg: OnElementInModelPropsArg): void ProtectedStatic InformationModel Called when an Element in an instance of a Model of this class is about to be updated.
onUpdated(_arg: OnModelIdArg): void ProtectedStatic InformationModel Called after a Model is updated.
onUpdatedElement(_arg: OnElementInModelIdArg): void ProtectedStatic InformationModel Called after an Element in an instance of a Model of this class has been updated.

Inherited properties

Name Type Inherited from Description
classFullName Accessor ReadOnly string InformationModel Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor StaticReadOnly string InformationModel Get the full BIS class name of this Entity in the form "schema:class"
className Accessor ReadOnly string InformationModel The name of the BIS class associated with this class.
id string InformationModel The Id of this Entity.
iModel IModelDb InformationModel The IModelDb that contains this Entity
isInstanceOfEntity Readonly "true" InformationModel An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
isPrivate boolean InformationModel  
isTemplate boolean InformationModel  
jsonProperties Readonly { T } InformationModel  
modeledElement Readonly RelatedElement InformationModel  
name Readonly string InformationModel  
parentModel Readonly string InformationModel  
schema Static undefined InformationModel The Schema that defines this class.
schemaName Accessor ReadOnly string InformationModel The name of the BIS Schema that defines this class

Defined in

Last Updated: 15 March, 2024