ExternalSourceIsInRepository Class

Relates an ExternalSource to the RepositoryLink that it is persisted in.

@note The associated ECClass was added to the BisCore schema in version 1.0.13

Extends

Methods

Name Description
constructor(repositoryId: string, relClassName: string = ExternalSourceIsInRepository.classFullName): ExternalSourceIsInRepository    

Inherited methods

Name Inherited from Description
toJSON(): RelatedElementProps RelatedElement  
fromJSON(json?: RelatedElementProps): undefined | RelatedElement Static RelatedElement  
idFromJson(json: any): string Static RelatedElement Accept the value of a navigation property that might be in the shortened format of just an id or might be in the full RelatedElement format.

Properties

Name Type Description
classFullName Static string    

Inherited properties

Name Type Inherited from Description
id Readonly string RelatedElement The Id of the element to which this element is related.
none StaticReadonly RelatedElement RelatedElement Used to null out an existing navigation relationship.
relClassName Readonly undefined | string RelatedElement The full className of the relationship class.

Defined in

Last Updated: 15 March, 2024