ViewDefinition3d Class

Defines a view of one or more 3d models.

Extends

Extended by

Methods

Name Description
constructor(props: ViewDefinition3dProps, iModel: IModelDb): ViewDefinition3d Protected    
loadDisplayStyle3d(): DisplayStyle3d Load this view's DisplayStyle3d from the IModelDb.  
toJSON(): ViewDefinition3dProps Obtain the JSON representation of this Entity.  

Inherited methods

Name Inherited from Description
collectPredecessorIds(predecessorIds: EntityReferenceSet): void Protected ViewDefinition Collect the Ids of this element's references at this level of the class hierarchy.
collectReferenceIds(referenceIds: EntityReferenceSet): void Protected ViewDefinition Collect the Ids of this entity's references at this level of the class hierarchy.
delete(): void ViewDefinition Delete this Element from the iModel.
forEachProperty(func: PropertyCallback, includeCustom: boolean = true): void ViewDefinition Call a function for each property of this Entity.
getAuxiliaryCoordinateSystemId(): string ViewDefinition The Id of the AuxiliaryCoordinateSystem for this ViewDefinition, or an invalid Id if no ACS is defined.
ViewDefinition Get the class metadata for this element.
getDisplayLabel(): string ViewDefinition Get a display label for this Element.
getJsonProperty(nameSpace: string): any ViewDefinition Get a JSON property of this element, by namespace
getPredecessorIds(): Id64Set ViewDefinition Get the Ids of this element's references.
getReferenceIds(): EntityReferenceSet ViewDefinition Get the set of this entity's entity references, EntityReferenceSet.
getToolTipMessage(): string[] ViewDefinition Get a list of HTML strings that describe this Element for the tooltip.
getUserProperties(namespace: string): any ViewDefinition Get a set of JSON user properties by namespace
insert(): string ViewDefinition Insert this Element into the iModel.
isDrawingView(): this is DrawingViewDefinition ViewDefinition Type guard for 'instanceof DrawingViewDefinition'
isSpatialView(): this is SpatialViewDefinition ViewDefinition Type guard for instanceof SpatialViewDefinition
isView2d(): this is ViewDefinition2d ViewDefinition Type guard for 'instanceof ViewDefinition2d`
isView3d(): this is ViewDefinition3d ViewDefinition Type guard for instanceof ViewDefinition3d
loadCategorySelector(): CategorySelector ViewDefinition Load this view's CategorySelector from the IModelDb.
loadDisplayStyle(): DisplayStyle ViewDefinition Load this view's DisplayStyle from the IModelDb.
removeUserProperties(nameSpace: string): void ViewDefinition Remove a set of JSON user properties, specified by namespace, from this Element
setAuxiliaryCoordinateSystemId(acsId: string): void ViewDefinition Set or clear the AuxiliaryCoordinateSystem for this ViewDefinition.
setJsonProperty(nameSpace: string, value: any): void ViewDefinition  
setUserProperties(nameSpace: string, value: any): void ViewDefinition Change a set of user JSON properties of this Element by namespace.
update(): void ViewDefinition Update this Element in the iModel.
createCode(iModel: IModelDb, scopeModelId: string, codeValue: string): Code Static ViewDefinition Create a Code for a ViewDefinition given a name that is meant to be unique within the scope of the specified DefinitionModel.
is(otherClass: undefined): boolean Static ViewDefinition return whether this Entity class is a subclass of another Entity class
onAllInputsHandled(_id: string, _iModel: IModelDb): void ProtectedStatic ViewDefinition Called on an element in a graph after all of its inputs have been processed and before its outputs are processed.
onBeforeOutputsHandled(_id: string, _iModel: IModelDb): void ProtectedStatic ViewDefinition Called when a root element in a subgraph is changed and before its outputs are processed.
onChildAdd(_arg: OnChildElementPropsArg): void ProtectedStatic ViewDefinition Called when an existing element is about to be updated so that an instance of this class will become its new parent.
onChildAdded(_arg: OnChildElementIdArg): void ProtectedStatic ViewDefinition Called after an existing element has been updated so that an instance of this class is its new parent.
onChildDelete(_arg: OnChildElementIdArg): void ProtectedStatic ViewDefinition Called when an element with an instance of this class as its parent is about to be deleted.
onChildDeleted(_arg: OnChildElementIdArg): void ProtectedStatic ViewDefinition Called after an element with an instance of this class as its parent was successfully deleted.
onChildDrop(_arg: OnChildElementIdArg): void ProtectedStatic ViewDefinition Called when an element with an instance of this class as its parent is about to be updated change to a different parent.
onChildDropped(_arg: OnChildElementIdArg): void ProtectedStatic ViewDefinition Called after an element with an instance of this class as its previous parent was updated to have a new parent.
onChildInsert(_arg: OnChildElementPropsArg): void ProtectedStatic ViewDefinition Called when a new element with an instance of this class as its parent is about to be inserted.
onChildInserted(_arg: OnChildElementIdArg): void ProtectedStatic ViewDefinition Called after a new element with an instance of this class as its parent was inserted.
onChildUpdate(_arg: OnChildElementPropsArg): void ProtectedStatic ViewDefinition Called when an element with an instance of this class as its parent is about to be updated.
onChildUpdated(_arg: OnChildElementIdArg): void ProtectedStatic ViewDefinition Called after an element with an instance of this the class as its parent was updated.
onDelete(arg: OnElementIdArg): void ProtectedStatic ViewDefinition Called before an Element is deleted.
onDeleted(_arg: OnElementIdArg): void ProtectedStatic ViewDefinition Called after an Element was deleted.
onInsert(arg: OnElementPropsArg): void ProtectedStatic ViewDefinition Called before a new Element is inserted.
onInserted(arg: OnElementIdArg): void ProtectedStatic ViewDefinition Called after a new Element was inserted.
onSubModelDelete(_arg: OnSubModelIdArg): void ProtectedStatic ViewDefinition Called when a sub-model of an instance of this class is being deleted.
onSubModelDeleted(_arg: OnSubModelIdArg): void ProtectedStatic ViewDefinition Called after a sub-model of an instance of this class was deleted.
onSubModelInsert(_arg: OnSubModelPropsArg): void ProtectedStatic ViewDefinition Called when an instance of this class is being sub-modeled by a new Model.
onSubModelInserted(_arg: OnSubModelIdArg): void ProtectedStatic ViewDefinition Called after an instance of this class was sub-modeled by a new Model.
onUpdate(arg: OnElementPropsArg): void ProtectedStatic ViewDefinition Called before an Element is updated.
onUpdated(_arg: OnElementIdArg): void ProtectedStatic ViewDefinition Called after an Element was updated.

Properties

Name Type Description
angles YawPitchRollAngles Rotation from world coordinates to view coordinates.  
camera Camera The camera used for this view, if cameraOn is true.  
cameraOn boolean If true, camera is used.  
details Accessor ReadOnly ViewDetails3d Provides access to optional detail settings for this view.  
extents Vector3d The extent (size) of the view frustum, in meters, along its x,y,z axes.  
origin Point3d The lower left back corner of the view frustum.  

Inherited properties

Name Type Inherited from Description
categorySelectorId string ViewDefinition The element Id of the CategorySelector for this ViewDefinition
classFullName Accessor ReadOnly string ViewDefinition Get the full BIS class name of this Entity in the form "schema:class".
classFullName Accessor StaticReadOnly string ViewDefinition Get the full BIS class name of this Entity in the form "schema:class"
className Accessor ReadOnly string ViewDefinition The name of the BIS class associated with this class.
code Code ViewDefinition The Code for this element
displayStyleId string ViewDefinition The element Id of the DisplayStyle for this ViewDefinition
federationGuid undefined | string ViewDefinition A FederationGuid assigned to this element by some other federated database
id string ViewDefinition The Id of this Entity.
iModel IModelDb ViewDefinition The IModelDb that contains this Entity
isInstanceOfEntity Readonly "true" ViewDefinition An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types
isPrivate boolean ViewDefinition If true, don't show this DefinitionElement in user interface lists.
jsonProperties Readonly { T } ViewDefinition Optional json properties of this element.
model Readonly string ViewDefinition The ModelId of the Model containing this element
parent undefined | RelatedElement ViewDefinition The parent element, if present, of this element.
requiredReferenceKeys StaticReadonly undefined ViewDefinition  
schema Static undefined ViewDefinition The Schema that defines this class.
schemaName Accessor ReadOnly string ViewDefinition The name of the BIS Schema that defines this class
userLabel undefined | string ViewDefinition A user-assigned label for this element.

Defined in

Last Updated: 16 April, 2024