RenderSchedule.TimelineEntryList<T extends RenderSchedule.TimelineEntry & { value: V }, P extends RenderSchedule.TimelineEntryProps, V> Class

A list of the RenderSchedule.TimelineEntry objects within a RenderSchedule.Timeline. The type parameters are:

  • T, a subclass of TimelineEntry with a value property specifying the value of the property controlled by the timeline at that entry's time point.
  • P, the JSON representation from which T is to be constructed.
  • V, the type of T.value.

Extended by

Implements

  • Iterable<T>

Methods

Name Description
constructor<T extends RenderSchedule.TimelineEntry<T> & { value: V }, P extends RenderSchedule.TimelineEntryProps, V>(props: P[], ctor: Constructor<T>): RenderSchedule.TimelineEntryList<T, P, V>    
[iterator](): Iterator<T, any, undefined> An iterator over the entries in the list.  
compareTo(other: RenderSchedule.TimelineEntryList<T, P, V>): number    
equals(other: RenderSchedule.TimelineEntryList<T, P, V>): boolean    
getEntry(index: number): undefined | T Look up an entry by its position in the list.  
getValue(index: number): undefined | V Look up the value of an entry by its position in the list.  
toJSON(): P[]    

Properties

Name Type Description
duration Readonly Range1d The total time period represented by the entries in this list.  
length Accessor ReadOnly number The number of entries in the list.  

Defined in

Last Updated: 16 April, 2024