RenderSchedule.TimelineEntry Class

Describes the value of some property at a specific point along a RenderSchedule.Timeline.

@see - RenderSchedule.VisibilityEntry

Extended by

Methods

Name Description
constructor(props: RenderSchedule.TimelineEntryProps): RenderSchedule.TimelineEntry    
compareTo(other: RenderSchedule.TimelineEntry): number    
equals(other: RenderSchedule.TimelineEntry): boolean    
toJSON(): RenderSchedule.TimelineEntryProps    

Properties

Name Type Description
interpolation Readonly RenderSchedule.Interpolation How to interpolate from this entry to the next entry in the timeline.  
time Readonly number The time point in seconds in the Unix Epoch.  

Defined in

Last Updated: 16 April, 2024