SkyBox Class

Describes how to draw a representation of a sky, as part of an Environment.

@see SkyBoxProps.

Extended by

Methods

Name Description
constructor(gradient: SkyGradient): SkyBox Protected    
toJSON(display?: boolean): SkyBoxProps Convert to JSON representation.  
createGradient(gradient?: SkyGradient): SkyBox Static Create a skybox that displays the specified gradient, or the default gradient if none is supplied.  
fromJSON(props?: SkyBoxProps): SkyBox Static Create from JSON representation.  

Properties

Name Type Description
defaults StaticReadonly SkyBox Default settings for a four-color gradient.  
gradient Readonly SkyGradient The gradient settings, used if no cube or sphere images are supplied, or if the images cannot be loaded.  

Defined in

Last Updated: 05 April, 2024