SkySphere Class

Describes how to draw a representation of a sky by mapping a single image to the interior of a sphere.

Extends

Methods

Name Description
constructor(image: string, gradient?: SkyGradient): SkySphere Create a new sky sphere using the specified image.  
toJSON(display?: boolean): SkyBoxProps See SkyBox.toJSON.  

Inherited methods

Name Inherited from Description
createGradient(gradient?: SkyGradient): SkyBox Static SkyBox Create a skybox that displays the specified gradient, or the default gradient if none is supplied.
fromJSON(props?: SkyBoxProps): SkyBox Static SkyBox Create from JSON representation.

Properties

Name Type Description
image Readonly string The image to map to the interior of the sphere.  

Inherited properties

Name Type Inherited from Description
defaults StaticReadonly SkyBox SkyBox Default settings for a four-color gradient.
gradient Readonly SkyGradient SkyBox The gradient settings, used if no cube or sphere images are supplied, or if the images cannot be loaded.

Defined in

Last Updated: 16 April, 2024