GeographicCRS Class

Geographic Coordinate Reference System implementation. This is the class that indicates the definition of a Geographic coordinate reference system comprised of three components: Horizontal and Vertical and an optional additional transform. The vertical component (see VerticalCRS) is the simplest portion containing a simple identifier as a string. The optional additional transform of which, currently, only the type Helmert 2D with Z offset Helmert2DWithZOffset is supported defines a transformation of x,y, and z cartesian coordinate of the projection to the final Geographic Coordinate Reference System cartesian coordinates. The horizontal component contains a list of identification and documentation properties as well as defining details possibly including the projection with method and parameters, the definition of the datum, ellipsoid, extent and so on. The principle of describing a Geographic CRS is that the definition may be incomplete. The whole set of classes related to geographic coordinate reference system classes (GeodeticEllipsoid, GeodeticDatum, Projection, GeodeticTransform, ...) are designed so that they can be parsed from incomplete JSON fragments, or produce incomplete JSON fragments such as would be generated from a request to a REST API to a server when select OData clauses are used. Often GeographicCRS would knowingly be created incomplete but with sufficient information to perform conversion from some reprojection engine (the present set of classes do not provide any GeographicCRS conversion). For example the following definitions are quite sufficient to request conversion to or from by a reprojection engine: { horizontalCRS: {id: "LL84"}, verticalCRS: {id:"GEOID"} or { horizontalCRS: {datumId: "WGS84", projection: {method: "None"}}, verticalCRS: "ELLIPSOID"} The reprojection engine will use the engine internal dictionary to obtain the details if it can. Some definitions will originate from other sources (a parsed WKT for example) and the reprojection engine will require all mathematical and operational details to perform any conversion (descriptive information are ignored in the conversion process).

@note see important detailed explanation in the HorizontalCRS, VerticalCRS and AdditionalTransform documentation.

@note Earth Centered, Earth Fixed coordinate system (ECEF) is a full 3D cartesian system that unambiguously expressed coordinates relative to the Earth Center. Since there is no horizontal portion independent from the vertical portion this system cannot be represented by a GeographicCRS and remains a separate concept.

Implements

Methods

Name Description
constructor(data?: GeographicCRSProps): GeographicCRS    
equals(other: GeographicCRS): boolean Compares two Geographic CRS.  
toJSON(): GeographicCRSProps Creates a JSON from the Geographic CRS definition  
fromJSON(data: GeographicCRSProps): GeographicCRS Static Creates a Geographic CRS from JSON representation.  

Properties

Name Type Description
additionalTransform Readonly undefined | AdditionalTransform The optional additional transform the geographic coordinate reference system.  
horizontalCRS Readonly undefined | HorizontalCRS The horizontal portion of the geographic coordinate reference system.  
verticalCRS Readonly undefined | VerticalCRS The vertical portion of the geographic coordinate reference system.  

Defined in

Last Updated: 15 March, 2024