getPlacements Method
Obtain the Placements of a set of GeometricElements.
getPlacements(elementIds: Iterable<string>, options?: Readonly<IModelConnection.GetPlacementsOptions>): Promise<Object[]>
@returns an array of placements, each having an additional elementId
property identifying the element from which the placement was obtained.
@note Any Id that does not identify a geometric element with a valid bounding box and origin is omitted from the returned array.
Parameter | Type | Description |
---|---|---|
elementIds | Iterable<string> | The Ids of the elements whose placements are to be queried. |
options | Readonly<IModelConnection.GetPlacementsOptions> | Options customizing how the placements are queried. |
Returns - Promise<Object[]>
an array of placements, each having an additional elementId
property identifying the element from which the placement was obtained.
Defined in
- core/frontend/src/IModelConnection.ts Line 1041
Last Updated: 04 December, 2023