getProps Method

Get an array of ElementProps given one or more element ids.

getProps(arg: Id64Arg): Promise<ElementProps[]>

@note This method returns all of the properties of the element (excluding GeometryStream), which may be a very large amount of data - consider using IModelConnection.query to select only those properties of interest to limit the amount of data returned.

Parameter Type Description
arg Id64Arg  

Returns - Promise<ElementProps[]>

Defined in

Last Updated: 15 March, 2024