IModelConnection.Views Class

The collection of views for an IModelConnection.

Methods

Name Description
convertViewStatePropsToViewState(viewProps: ViewStateProps): Promise<ViewState> Return the ViewState object associated with the ViewStateProps passed in.  
getThumbnail(_viewId: string): Promise<ThumbnailProps> Get a thumbnail for a view. Deprecated  
getViewList(queryParams: ViewQueryParams): Promise<IModelConnection.ViewSpec[]> Get an array of the ViewSpecs for all views in this IModel that satisfy a ViewQueryParams.  
load(viewDefinitionId: string): Promise<ViewState> Load a ViewState object from the specified ViewDefinition id.  
queryDefaultViewId(): Promise<string> Query the Id of the default ViewDefinition, if any, stored in this iModel's property table. Deprecated  
queryProps(queryParams: ViewQueryParams): Promise<ViewDefinitionProps[]> Query for an array of ViewDefinitionProps  

Properties

Name Type Description
viewsStoreReader Accessor ReadOnly PickAsyncMethods<Reader>    
viewStoreWriter Accessor ReadOnly PickAsyncMethods<Writer>    

Defined in

Last Updated: 16 April, 2024