TentativeOrAccuSnap Class

TentativeOrAccuSnap returns information about an active snap generated by either AccuSnap or TentativePoint.

Methods

Name Description
constructor(): TentativeOrAccuSnap    
getCurrentPoint(): Point3d Static    
getCurrentSnap(checkIsHot: boolean = true): undefined | SnapDetail Static Get the current snap from either AccuSnap or TentativePoint.  
getCurrentView(): undefined | ScreenViewport Static    

Properties

Name Type Description
isHot Accessor StaticReadOnly boolean    

Defined in

Last Updated: 16 April, 2024