DrawingModelState Class

Represents the front-end state of a DrawingModel.

Extends

Extended by

Methods

Name Description
constructor(props: GeometricModel2dProps, iModel: IModelConnection, state?: GeometricModel2dState): DrawingModelState    

Inherited methods

Name Inherited from Description
clone(iModel?: IModelConnection): DrawingModelState GeometricModel2dState Make an independent copy of this EntityState
equals(other: DrawingModelState): boolean GeometricModel2dState Return true if this EntityState is equal to another one.
queryModelRange(): Promise<Range3d> GeometricModel2dState Query for the union of the ranges of all the elements in this GeometricModel.
toJSON(): GeometricModel2dProps GeometricModel2dState Add all custom-handled properties of a Model to a json object.

Properties

Name Type Description
className Accessor StaticReadOnly string The name of the BIS class associated with this class.  

Inherited properties

Name Type Inherited from Description
asGeometricModel3d Accessor ReadOnly undefined | GeometricModel3dState GeometricModel2dState Attempts to cast this model to a 3d geometric model.
asSpatialModel Accessor ReadOnly undefined | SpatialModelState GeometricModel2dState Attempts to cast this model to a spatial model.
classFullName Accessor StaticReadOnly string GeometricModel2dState Get full BIS class name of this Entity in the form "SchemaName:ClassName".
classFullName Readonly string GeometricModel2dState The full class name in the form "schema:class".
className Accessor ReadOnly string GeometricModel2dState The name of the BIS class associated with this class.
id Readonly string GeometricModel2dState The Id of this Entity.
iModel Readonly IModelConnection GeometricModel2dState The iModel from which this Entity was loaded
is2d Accessor ReadOnly boolean GeometricModel2dState Returns true if this is a 2d model (a GeometricModel2dState).
isPrivate Readonly boolean GeometricModel2dState  
isTemplate Readonly boolean GeometricModel2dState  
jsonProperties Readonly { T } GeometricModel2dState Optional json properties of this Entity.
modeledElement Readonly RelatedElement GeometricModel2dState  
name Readonly string GeometricModel2dState  
parentModel string GeometricModel2dState  
schemaName Accessor StaticReadOnly string GeometricModel2dState The name of the BIS schema for this class.

Defined in

Last Updated: 15 March, 2024