EngineeringLengthDescription Class

Engineering Length Property Description

Extends

Methods

Name Description
constructor(name?: string, displayLabel?: string, iconSpec?: string): EngineeringLengthDescription    

Inherited methods

Name Inherited from Description
formatValue(numberValue: number): string Protected FormattedQuantityDescription  
parseString(userInput: string): ParseResults Protected FormattedQuantityDescription  

Properties

Name Type Description
formatterQuantityType Accessor ReadOnly QuantityType    
parseError Accessor ReadOnly string    
quantityType Accessor ReadOnly string    

Inherited properties

Name Type Inherited from Description
displayLabel string FormattedQuantityDescription  
editor PropertyEditorInfo FormattedQuantityDescription  
format (numberValue: number) => string FormattedQuantityDescription  
formatterSpec Accessor ReadOnly undefined | FormatterSpec FormattedQuantityDescription  
name string FormattedQuantityDescription  
parse (userInput: string) => ParseResults FormattedQuantityDescription  
parserSpec Accessor ReadOnly undefined | ParserSpec FormattedQuantityDescription  
typename string FormattedQuantityDescription  

Defined in

Last Updated: 15 March, 2024