RenderSystem.Options Interface

Options passed to supplyRenderSystem to configure the RenderSystem on startup. Many of these options serve as "feature flags" used to enable newer, experimental features. As such they typically begin life tagged as "alpha" or "beta" and are subsequently deprecated when the feature is declared stable.

Properties

Name Type Description
antialiasSamples number | undefined Initial antialias setting.  
devicePixelRatioOverride number | undefined If defined, this will be used as the device pixel ratio instead of the system's actual device pixel ratio.  
disabledExtensions WebGLExtensionName[] | undefined WebGL extensions to be explicitly disabled, regardless of whether or not the WebGL implementation supports them.  
displaySolarShadows boolean | undefined If true, display solar shadows when enabled by ViewFlags.shadows.  
doIdleWork boolean | undefined To help prevent delays when a user interacts with a Viewport, the WebGL render system can precompile shader programs before any Viewport is opened.  
dpiAwareLOD boolean | undefined If true, ScreenViewports will take into account the DPI of the display when computing the level of detail for tile graphics and decorations.  
dpiAwareViewports boolean | undefined If true, ScreenViewports will respect the DPI of the display.  
errorOnMissingUniform boolean | undefined If true, will cause exception when a shader uniform is missing (usually optimized out), otherwise will only log these.  
logarithmicDepthBuffer boolean | undefined If the view frustum is sufficiently large, and the EXT_frag_depth WebGL extension is available, use a logarithmic depth buffer to improve depth buffer resolution.  
planProjections boolean | undefined If true, plan projection models will be rendered using PlanProjectionSettings defined by the DisplayStyle3dState.  
preserveShaderSourceCode boolean | undefined If true, preserve the shader source code as internal strings, useful for debugging purposes.  
useWebGL2 boolean | undefined Previously, this property dictated whether to attempt to use a WebGL 2 rendering context before falling back to WebGL 1. Deprecated  

Defined in

Last Updated: 13 May, 2024