constructor MethodProtected

Construct a new rectangle with angles specified in radians.

MapCartoRectangle(west: number, south: number, east: number, north: number): MapCartoRectangle

@note If north is less than south, they will be swapped.

@see fromRadians, fromDegrees, createZero, and createMaximum to construct a new rectangle.

Parameter Type Description
west number The western longitude in radians, in [-pi, pi].
south number The southern latitude in radians, in [-pi/2, pi/2].
east number The eastern latitude in radians, in [-pi, pi].
north number The northern latitude in radians, in [-pi/2, pi/2].

Returns - MapCartoRectangle

Defined in

Last Updated: 13 May, 2024